View Issue Details

IDProjectCategoryView StatusLast Update
0008445Multi Theft Auto : San AndreasServerpublic2016-01-25 00:51
ReporterWAssigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.5 
Target Version1.5.2Fixed in Version1.5.2 
Summary0008445: [Request] fetchRemote https:// support
Description

It would be cool if we could use fetch data from https:// with fetchRemote.

TagsNo tags attached.

Activities

Gallardo9944

2014-08-12 15:03

viewer   ~~0021748

I support this, SSL is a nice feature to have, which I can't install on my apache cause MTA won't be able to communicate with my php scripts then.

johny46

2015-09-18 20:20

viewer   ~~0024092

I also support this request. There's a lot of web apis which will not accept plain HTTP connections, one of which being the YouTube Data API which can be especially important given the recent addition of the in-game web browser.
You could for example want to give your players a way of requesting their favorite music clips from YouTube after they've been validated (eg. length limit). Such validation will require the use of YouTube api in order to retrieve the duration and clip title through simple means (JSON).

JBoy

2015-09-18 20:23

viewer   ~~0024093

Obama approves. So do I.

Necktrox

2015-09-22 12:07

developer   ~~0024099

(Unrelated to ticket)

@johny46: I recommend you to create your own API for your server. You can change the code on your webserver without touching the running MTA server and causing more problems.

nokizorque

2015-11-16 10:15

viewer   ~~0024163

https://github.com/multitheftauto/mtasa-blue/pull/16

rafalh

2015-12-29 17:00

viewer   ~~0024265

What about Linux support? I got ERROR 1 when trying to fetch HTTPS resource.

qaisjp

2015-12-29 17:13

administrator   ~~0024266

shot in the dark, do you have openssl installed? if not, install it and see if that changes anything

ccw

2015-12-31 16:42

administrator   ~~0024272

Last edited: 2015-12-31 16:43

View 2 revisions

Try latest 1.5 Linux build from here: https://nightly.mtasa.com/

rafalh

2016-01-25 00:51

viewer   ~~0024351

Works for me in 1.5.2 R2 (on Debian 8). Thanks!

Issue History

Date Modified Username Field Change