View Issue Details

IDProjectCategoryView StatusLast Update
0008419Multi Theft Auto : San AndreasClientpublic2014-11-20 20:25
ReporterDutchman101Assigned Toccw 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008419: Spawning player can make the ground collisionless
Description

If player spawns in area (like centre of map: blueberry) it can render the ground and area collisionless.

See the video to understand what happens, it's a weird kind of bug and for this example affects a notable part of blueberry. (until where house blocks separate, see video at the end)

Steps To Reproduce

Reproduction video: https://www.youtube.com/watch?v=nMaKJIY0T24 (0:53 best example)

Additional Information

The ground around the player will be collisionless for example, projectiles (rocket used in example) but not for standing onto it obviously.

I have also seen something similar in areas around network trouble'd players or timing players.

TagsNo tags attached.

Activities

ccw

2014-08-01 13:06

administrator   ~~0021608

Looks like onClientExplosion is being cancelled

Dutchman101

2014-08-01 13:14

updater   ~~0021609

Last edited: 2014-08-01 13:19

View 2 revisions

there was no script doing so, this happens on infact all servers, mta spawns players near that area for certain timespace by default (not sure myself why but think its GTA) 1 takes longer than other player to move themselves to serverspawn/finish loading and if longer, the area will be collisionless for explosions and that could obstruct something? (1:47 on the video) no idea how it happens though

if it happens around timing/network troubling player it seems the area is less big and more just the ground near to him

arranTuna

2014-08-01 15:26

manager   ~~0021612

Confirmed with Server v1.4-release-6754 Client v1.4-release-6753

Rockets were going through the ground sometimes and only at that farm.

Grafu

2014-08-01 16:09

viewer   ~~0021613

This is because most of the loading players go to the center of the map. And this bug occurs when a player loses connection to the server and doesn't time out. Firing rockets at him will make them disappear. This bug is related to players with frozen ping.

Dutchman101

2014-08-01 16:32

updater   ~~0021614

Yeah that could be 1 of the cases the bug appears, but as i said it also happens sometime when player in the process of timing out, network troubling, or elsehow depending on their net recovery to either time or stay on and regain connectivity, but then in limited area, unlike the center of the map (while they load) where the bug affects half of the city beginning (blueberry, as video 1:47) so there it could be a problem, where if a player has trouble with their net as described just limits the area it happens to like some feet away of them.

Dutchman101

2014-08-12 20:31

updater   ~~0021752

@ccw, but i wonder, how can onClientExplosion be cancelled, when there is no script or anything known doing that? would that mean players timing out/spawning/network troubling trigger something in GTA that disables processing of explosions?

Grafu

2014-08-12 20:42

viewer   ~~0021754

Since the damage is actually being synced to the damaged player, all damage to the timed out player gets cancelled due to failed callback (server gets no answer from a timed out person), explosions get cancelled the same way.

Dutchman101

2014-08-12 21:41

updater   ~~0021755

Last edited: 2014-08-12 21:42

View 2 revisions

but how can that affect half of a city? (farm, centre spawnpoint)
and if player times/network troubles, cancel it around the area he's at..

that would mean all explosions gets synced by the most near player, can't be true as 1. would be inefficient: if you shoot at the area near, to let it be synced by a random player, so isn't likely MTA does it that way,

and 2. it happens not only when you fire directly on the player but even if you didn't yet do so, but just in the area near. the problem is more, that ground cancels the explosions far from someone spawning, (can be obstructing) or when someone lags/network troubles just a smaller area. the 2 cases are similar, but 1 can be more of a problem than the other, in either ways

(for 1. central farm, half of the city will be collisionless for explosions, not a problem unless someone has his server with that city (blueberry) as central point, making them unable to correctly fight with RPGs and projectiles there, it even applies everywhere not only the ground, see the first video)

(and 2. if it happens to player timing out/network troubling, and due to mta's network reliability it takes quite some time before he actually disconnects, it can obstruct the area he was at aslong he network troubles/is in the process of timing: cancelled explosions could create problems for the players near)

And grafu for your explanation, i don't think that if you shoot an RPG meters away like far back in blueberry, the player near will sync that shot, because that isn't near.

Dutchman101

2014-08-20 00:08

updater   ~~0021812

Last edited: 2014-11-20 14:28

View 3 revisions

test fix:
https://code.google.com/p/mtasa-blue/source/detail?r=6805

Edit: forgot about this, but i can confirm it's fully fixed now

Issue History

Date Modified Username Field Change