View Issue Details

IDProjectCategoryView StatusLast Update
0008407Multi Theft Auto : San AndreasVehiclespublic2014-08-02 03:35
ReportersocialzAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8.1
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008407: Vehicle gets frozen when setting its model while in it
Description

I was just switching from 1.3.5 to 1.4 and noticed this very interesting problem with vehicle models. I am using a command to set the model of your current vehicle and it has worked just fine before, until now it just blocks me from doing it properly.

So, if you create the vehicle and set the model while no one is occupying it, it works just fine, but if there is someone occupying the vehicle, it just blocks you from moving the vehicle (tires are spinning, and some very small velocity).

Player inside a vehicle:

srun a = createVehicle( 567, 0, 0, 3 ) warpPedIntoVehicle( getPlayerFromName( "Socialz" ), a ) setElementModel( a, 568 )

Ped inside a vehicle:

crun a = createVehicle( 567, 0, 0, 3 ) b = createPed( 0, 0, 0, 3 ) warpPedIntoVehicle( b, a ) setElementModel( a, 568 ) setPedControlState( b, "accelerate", true )

Using setElementVelocity( ) however works:

srun a = createVehicle( 567, 0, 0, 3 ) warpPedIntoVehicle( getPlayerFromName( "Socialz" ), a ) setElementModel( a, 568 ) setElementVelocity( a, 0.2, 0.2, 0.2 )

crun a = createVehicle( 567, 0, 0, 3 ) b = createPed( 0, 0, 0, 3 ) warpPedIntoVehicle( b, a ) setElementModel( a, 568 ) setElementVelocity( a, 0.2, 0.2, 0.2 )

Steps To Reproduce
  1. Create vehicle
  2. Occupy it with a player or a pedestrian, both do the same thing
  3. Make the vehicle accelerate
  4. much accelerate wow
TagsNo tags attached.

Activities

socialz

2014-07-31 17:25

viewer   ~~0021567

Last edited: 2014-07-31 17:33

View 5 revisions

And forgot to add, that setElementFrozen( ) does not work on neither.

srun a = createVehicle( 567, 0, 0, 3 ) warpPedIntoVehicle( getPlayerFromName( "Socialz" ), a ) setElementModel( a, 568 ) setElementFrozen( a, false )

crun a = createVehicle( 567, 0, 0, 3 ) b = createPed( 0, 0, 0, 3 ) warpPedIntoVehicle( b, a ) setElementModel( a, 568 ) setElementFrozen( a, false ) setPedControlState( b, "accelerate", true )

In addition after this has occurred vehicle handling is totally screwed up. Steering is very slippery and nearly impossible to handle properly. It fixes itself when you re-enter the vehicle.

Unix

2014-07-31 17:35

viewer   ~~0021568

What MTA build are you using with this?

socialz

2014-07-31 18:14

viewer   ~~0021570

Last edited: 2014-07-31 18:17

View 2 revisions

MTA:SA Server v1.4-release-6692
Multi Theft Auto v1.4-release-6751

Should it be because of the fact that the server is lower version than my client? Though, it still occurs on client-side code, so not sure about that neither.

arranTuna

2014-07-31 18:18

manager   ~~0021571

You could always try updating the server since 6692 is quite old but if it's freezing then it's a client side problem. Maybe it's to do with that ground loading thing freezing it.

Unix

2014-07-31 18:20

viewer   ~~0021572

Try with client 6753, vehicle handling is better with that version.

socialz

2014-07-31 19:30

viewer   ~~0021574

6753 seems to have fixed this problem. This is very easy to reproduce so I hope you guys will maybe push a small batch of critical updates soon up to the release version if just possible, otherwise we'll have to keep rerouting people to get the latest nightly for that matter.

Issue History

Date Modified Username Field Change