View Issue Details

IDProjectCategoryView StatusLast Update
0008366Multi Theft Auto : San AndreasClientpublic2014-07-21 00:32
ReporterarranTunaAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008366: Remington with suspensionLowerLimit of 0 breaks the game
Description

Get inside a Remington
srun setVehicleHandling(getPedOccupiedVehicle(you), "suspensionLowerLimit", 0)
FPS drops to 1.

TagsNo tags attached.

Activities

arranTuna

2014-07-18 16:01

manager   ~~0021376

And variables like 0.00001 make your vehicle fly off into space.

StifflersMom

2014-07-19 01:35

updater   ~~0021377

The remington "fly off" is -0.00001

Additionally, this effect is always there, if the suspensionLowerLimit equals to suspensionUpperLimit.

If you read the wiki, it's described there (suspensionLowerLimit ... Can't be equal to suspensionUpperLimit. and vice versa)

For me, that's no bug.

Grafu

2014-07-19 02:20

viewer   ~~0021378

Stifflers, please don't go off-topic. We're talking about the fps drop.

arranTuna

2014-07-19 12:10

manager   ~~0021381

It says it can't be the same, it doesn't say your game will break if they're the same. If there is a script that lets players change these things and it doesn't have a check to make sure they're not the same players will never know why their game breaks.

StifflersMom

2014-07-20 03:40

updater   ~~0021384

I thought about my prevous comment and I decided to remove it. I don't change my mind about "for me, that's no bug". Arran is right, it may confuse people, who playing around with some settings and get fps drops. It will be better to edit the wiki, because there are many more things, which produce fps drops, if the arguments are not proper set.

Grafu

2014-07-20 08:28

viewer   ~~0021385

Sure

Cazomino05

2014-07-21 00:31

reporter   ~~0021392

fixed in r6699 - https://code.google.com/p/mtasa-blue/source/detail?r=6699

Issue History

Date Modified Username Field Change