View Issue Details

IDProjectCategoryView StatusLast Update
0008363Multi Theft Auto : San AndreasClientpublic2014-07-21 03:35
ReporterStifflersMomAssigned ToCazomino05 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008363: 1.4-release-6686 attachTrailerToVehicle client side with trains can freeze client
Description

If you attach two trains by the wrong way, it will freeze the client.

Steps To Reproduce

runcode:
crun train1=createVehicle(570,-1935.74963, 197.00211, 25.64925)
crun train2=createVehicle(570,-1935.74963, 197.00211, 25.64925)
crun attachTrailerToVehicle(train1,train2)
crun attachTrailerToVehicle(train2,train1)

Client will freeze, if the vehicles are streamed in.

TagsNo tags attached.

Activities

Dutchman101

2014-07-18 02:48

updater   ~~0021373

I confirm. reproduced it and triggered crash dump generation after it froze (debug.txt)

so the cause should be inside this dump:
https://mega.co.nz/#!EMEzQaZY!wPl2KKnOkeIS6ReBMQBSW5EkDd-2DCiau3rqSQqtbIk

Cazomino05

2014-07-21 03:35

reporter   ~~0021393

fixed in r6700 - https://code.google.com/p/mtasa-blue/source/detail?r=6700

Issue History

Date Modified Username Field Change