View Issue Details

IDProjectCategoryView StatusLast Update
0008331Multi Theft Auto : San AndreasMap Editorpublic2014-07-06 14:17
ReporterKain-Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008331: Mapping in train tunnels not showing
Description

Okay so first off, I decided to map a TDM map in the west LS train station however I came across an issue with mapping it. I began by taking my camera into the train station where there is also a tunnel inside. (Bear in mind we're now underground). I wanted to map and place items on the train track however this is where the issue came across. If my camera was in the station still and not directly over the tracks, I could visually see the item that I had just placed. The main issue is when I move my camera over the tracks the items visually disappear but you can still detect them when you roll your cursor over them. (This also occurs when you attempt to map directly over the tracks). Basically I can't map on the train track inside the station or inside the tunnel.

Steps To Reproduce
  1. Go to the west LS train station while in map editor
  2. Follow the steps down so you are underground and can seen the station.
  3. Choose a relatively small item from the objects menu and attempt to place it on the train tracks.
  4. Move your camera from the station over to the tracks and see it vanish
  5. Notice how the object is physically there but not visually

(I tried this out with a friend and he had the same issue)

Additional Information

I'm not 100% sure if this is a bug or if it's supposed to be like this however a lad in #mta.scripting told me to post a bug report here so I did :/

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 1

2014-07-05 21:27: Kain- (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 1)

Activities

arranTuna

2014-07-02 00:06

manager   ~~0021204

Detailed report, but I think that the saying: "a picture says a thousand words" would apply to this report, please take a screenshot of this bug and upload it to the internet.

johny46

2014-07-02 00:45

viewer   ~~0021205

arranTuna: how many words does a video say then? :P

http://youtu.be/QaNvEfDBl3A

Grafu

2014-07-02 01:19

viewer   ~~0021207

This bug existed for a long time and applies for some car parks (valet missions one, lvpd)

ccw

2014-07-02 01:51

administrator   ~~0021208

Try turning off occlusions
https://wiki.multitheftauto.com/wiki/SetOcclusionsEnabled

Kain-

2014-07-02 21:03

viewer   ~~0021215

Cheers johny46 for making that video <3
Just incase anyone didn't click on the link, here it is again: http://youtu.be/QaNvEfDBl3A

ccw, i did actually attempt the occlusions thing last night but i forgot to mention :P

I'm a rather crap scripter so i'll add the resource i created/tested which failed to work. I did try it as both "true" and "false" but neither worked. The resource will be an attached file.

Kain-

2014-07-02 21:07

viewer   ~~0021216

Apparently the attached file doesn't want to work, here's a dropbox link:

https://www.dropbox.com/s/mge4hn2iscia2it/occlusions.zip

cheers

johny46

2014-07-02 21:29

viewer   ~~0021218

Last edited: 2014-07-02 21:30

View 2 revisions

I can confirm that both clientside and serverside variations of setOcclusionsEnabled function don't change anything in this issue.

I have also noticed something really weird and recorded a new video:
http://youtu.be/JEgRKx8gwTg

I think it may be a bug within San Andreas itself because it is a bit too much weird to be MTA's issue :)

Kain-

2014-07-05 21:28

viewer   ~~0021247

I hope the sponsor takes paypal, should've check before doing so xD

lopezloo

2014-07-06 05:23

developer   ~~0021248

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6651

Issue History

Date Modified Username Field Change