View Issue Details

IDProjectCategoryView StatusLast Update
0008301Multi Theft Auto : San AndreasScriptingpublic2014-07-06 14:39
Reporterjohny46Assigned ToCazomino05 
PrioritynoneSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008301: Enable Opus encoded audio files playback in playSound and playSound3D functions
Description

With Opus codec becoming more popular due to its outstanding quality to file size ratio, I think it would be of use to scripters if it was supported by MTA's audio functions.

As far as I know, MTA uses the BASS audio library to implement audio functions, which has already got an Opus extension made by the original authors called "BASSOPUS", so it shouldn't be (or at least it doesn't seem to be) too hard to implement it.

Using Opus encoded files in gamemodes and scripts could minimize the bandwidth usage of servers because using Opus, you can achieve a better quality file at lower file size.

TagsNo tags attached.

Activities

Talidan

2014-06-26 12:18

administrator   ~~0021124

It was always my intention to replace voice with Opus at some point too.

Cazomino05

2014-07-06 14:39

reporter   ~~0021253

fixed in r6650
https://code.google.com/p/mtasa-blue/source/detail?r=6650

Issue History

Date Modified Username Field Change