View Issue Details

IDProjectCategoryView StatusLast Update
0008294Multi Theft Auto : San AndreasServerpublic2014-07-17 20:04
ReporterWAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityN/A
Status resolvedResolutionfixed 
Platformv1.4-r6598-release 64bitOSLinuxOS Version
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008294: Linux 1.4 server crash
Description

Server crashed after running for about 12 hours.

Last lines from server.log: http://upload.mtasa.com/u/339392648/server.log.txt_

Additional Information

MTA:SA Server v1.4-r6598-release crash report.
2014-06-22 22:49
Caught 12 addresses ...

Backtrace:
#0 - ./x64/core.so(_ZN13CCrashHandler21HandleExceptionGlobalEi+0x6a) [0x7fcc32c4d84a]
#1 - /lib/x86_64-linux-gnu/libc.so.6(+0x324f0) [0x7fcc330c54f0]
#2 - /lib/x86_64-linux-gnu/libc.so.6(+0x76fed) [0x7fcc33109fed]
#3 - /lib/x86_64-linux-gnu/libc.so.6(+0x794d4) [0x7fcc3310c4d4]
#4 - /lib/x86_64-linux-gnu/libc.so.6(__libc_malloc+0x70) [0x7fcc3310ec00]
#5 - /usr/lib/x86_64-linux-gnu/libstdc++.so.6(_Znwm+0x1d) [0x7fcc33f3d07d]
#6 - /home/mp/servers/s4464/x64/net.so(_ZN13CNetServerDLL26AllocateNetServerBitStreamEt+0x50) [0x7fcc321b5a20]
#7 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN7CPlayer4SendERK7CPacket+0xb1) [0x7fcc3189b0d1]
#8 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN16CPerPlayerEntity13DestroyEntityEP7CPlayer+0xcb) [0x7fcc31897eeb]
#9 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN16CPerPlayerEntity15UpdatePerPlayerEv+0x80) [0x7fcc31897d40]
#10 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN8CElement23UpdatePerPlayerEntitiesEv+0xf) [0x7fcc317fcf1f]
#11 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN8CElement23UpdatePerPlayerEntitiesEv+0x29) [0x7fcc317fcf39]

TagsNo tags attached.

Activities

W

2014-06-23 10:17

viewer   ~~0021081

as sx320 noted, it may be related to http://bugs.mtasa.com/view.php?id=7565

One URL that I'm periodically calling with fetchRemote was correct but unaccessible for about one hour before the crash.

W

2014-06-24 06:12

viewer   ~~0021094

Last edited: 2014-06-24 06:42

View 1 revisions

Second crash occured after running for about 23 hours:

Memory usage: http://lbiegaj.netshock.pl/_/screen_20140624-706281007028.png

Last lines from server.log:
[2014-06-23 21:31:41] CONNECT: EightMouse49 connected (IP: x.x.x.x Serial: **** Version: 1.4.0-9.06599.0)
[2014-06-23 21:31:41] JOIN: SqualidWrist39 joined the game (IP: x.x.x.x)
[2014-06-23 21:31:41] QUIT: Tom9122 left the game [Timed out]

Crash report:
MTA:SA Server v1.4-r6598-release crash report.
2014-06-23 21:31
Caught 14 addresses ...

Backtrace:
#0 - ./x64/core.so(_ZN13CCrashHandler21HandleExceptionGlobalEi+0x6a) [0x7fbbbb1b684a]
#1 - /lib/x86_64-linux-gnu/libc.so.6(+0x324f0) [0x7fbbbb62e4f0]
#2 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN14CPlayerManager14RemoveFromListEP7CPlayer+0x181) [0x7fbbb9e0e781]
#3 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN7CPlayer6UnlinkEv+0x13) [0x7fbbb9e04193]
#4 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN7CPlayerD0Ev+0x14c) [0x7fbbb9e0790c]
#5 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN15CElementDeleter11DoDeleteAllEv+0x1f) [0x7fbbb9d6ecbf]
#6 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN5CGame7DoPulseEv+0x373) [0x7fbbb9d7f0b3]
#7 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN7CServer7DoPulseEv+0x7b) [0x7fbbb9c85dbb]
#8 - ./x64/core.so(_ZN11CServerImpl8MainLoopEv+0xe1) [0x7fbbbb1b8521]
#9 - ./x64/core.so(_ZN11CServerImpl3RunEiPPc+0x981) [0x7fbbbb1b9671]
#10 - ./x64/core.so(Run+0x35) [0x7fbbbb1ce3b5]
#11 - ./mta-server() [0x400f87]
#12 - /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xfd) [0x7fbbbb61aead]
#13 - ./mta-server() [0x400b09]

MTA:SA Server v1.4-r6598-release crash report.
2014-06-23 21:31
Caught 6 addresses ...

Backtrace:
#0 - ./x64/core.so(_ZN13CCrashHandler21HandleExceptionGlobalEi+0x6a) [0x7fbbbb1b684a]
#1 - /lib/x86_64-linux-gnu/libc.so.6(+0x324f0) [0x7fbbbb62e4f0]
#2 - /home/mp/servers/s4464/x64/net.so(_ZN13CNetServerDLL7DoPulseEv+0xa4) [0x7fbbba72b3a4]
#3 - /home/mp/servers/s4464/x64/deathmatch.so(_ZN16CNetServerBuffer10ThreadProcEv+0x365) [0x7fbbb9f6ee55]
#4 - /lib/x86_64-linux-gnu/libpthread.so.0(+0x6b50) [0x7fbbbb3e6b50]
#5 - /lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fbbbb6d80ed]

Cazomino05

2014-06-24 07:12

reporter   ~~0021095

dropped revision containing user IP addresses.

W

2014-06-24 14:51

viewer   ~~0021096

after dutchman101 request, I've switched back to 1.4 32-bit, next crash occured few hours after that:

MTA:SA Server v1.4-r6599-release crash report.
2014-06-24 14:43
Caught 17 addresses ...

Backtrace:
#0 - ./core.so(_ZN13CCrashHandler21HandleExceptionGlobalEi+0x69) [0xf74c2639]
#1 - [0xf77d4400]
#2 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN10SharedUtil13MapRemovePairI7SStringP8CAccountSt4lessIS1_ESsS3_EEvRSt8multimapIT_T0_T1_SaISt4pairIKS7_S8_EEERKT2RKT3+0x2d) [0xf6bfaf4d]
#3 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN15CAccountManager14RemoveFromListEP8CAccount+0x36) [0xf6bf4626]
#4 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN8CAccountD1Ev+0x4a) [0xf6bef59a]
#5 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN7CClientD2Ev+0x41) [0xf6c04d51]
#6 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN7CPlayerD0Ev+0x449) [0xf6cdbc69]
#7 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN15CElementDeleter11DoDeleteAllEv+0x27) [0xf6c38237]
#8 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN5CGame7DoPulseEv+0x425) [0xf6c4aad5]
#9 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN7CServer7DoPulseEv+0x78) [0xf6b3a398]
#10 - ./core.so(_ZN15CModManagerImpl7DoPulseEv+0x18) [0xf74c2f58]
#11 - ./core.so(_ZN11CServerImpl8MainLoopEv+0xb9) [0xf74c4529]
#12 - ./core.so(_ZN11CServerImpl3RunEiPPc+0xce9) [0xf74c5a79]
#13 - ./core.so(Run+0x46) [0xf74dcef6]
#14 - ./mta-server() [0x8048e1d]
#15 - /lib/i386-linux-gnu/i686/cmov/libc.so.6(libc_start_main+0xe6) [0xf7522e46]
#16 - ./mta-server(
gxx_personality_v0+0x49) [0x8048891]

MTA:SA Server v1.4-r6599-release crash report.
2014-06-24 14:43
Caught 7 addresses ...

Backtrace:
#0 - ./core.so(_ZN13CCrashHandler21HandleExceptionGlobalEi+0x69) [0xf74c2639]
#1 - [0xf77d4400]
#2 - /home/mp/servers/s4464/net.so(_ZN13CNetServerDLL7DoPulseEv+0xee) [0xf713399e]
#3 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN16CNetServerBuffer10ThreadProcEv+0x234) [0xf6e60bb4]
#4 - /home/mp/servers/s4464/mods/deathmatch/deathmatch.so(_ZN16CNetServerBuffer16StaticThreadProcEPv+0x31) [0xf6e60cc1]
#5 - /lib/i386-linux-gnu/i686/cmov/libpthread.so.0(+0x5c39) [0xf74f7c39]
#6 - /lib/i386-linux-gnu/i686/cmov/libc.so.6(clone+0x5e) [0xf75e2d4e]

I'm switching back to 1.3.5 atm, but if it's needed then I'll revert to 1.4.

ccw

2014-06-30 06:52

administrator   ~~0021184

Please try:
http://nightly.mtasa.com/multitheftauto_linux-1.4.0-rc-6622-net1D8.tar.gz

If it crashes, upload the dump file which is now found in mods/deathmatch/dumps/

W

2014-07-02 16:44

viewer   ~~0021212

Last edited: 2014-07-02 16:45

View 2 revisions

http://upload.mtasa.com/u/874665432/server_1.4-release-6622_20140702_1616.dmp_

~6 hours of uptime, ~ 450 players, normal memory usage just before crash.

Hitori

2014-07-02 23:10

viewer   ~~0021221

Last edited: 2014-07-03 18:56

View 3 revisions

Hi all.
There are crash dumps for the same version of server:
http://upload.mtasa.com/u/144190395/server_1.4-release-6622_20140701_1255.dmp_
http://upload.mtasa.com/u/462376391/server_1.4-release-6622_20140701_1258.dmp_
http://upload.mtasa.com/u/350380901/server_1.4-release-6622_20140702_2243.dmp_

http://upload.mtasa.com/u/995603965/server_1.4-release-6622_20140703_1218.dmp_
http://upload.mtasa.com/u/241228705/server_1.4-release-6622_20140703_1418.dmp_
http://upload.mtasa.com/u/701112738/server_1.4-release-6622_20140703_1449.dmp_
http://upload.mtasa.com/u/521523684/server_1.4-release-6622_20140703_1802.dmp_

OS: Linux Debian-70-wheezy-32

Dutchman101

2014-07-03 21:11

updater   ~~0021231

Last edited: 2014-07-03 21:12

View 2 revisions

@Hitori, it isn't needed to keep bumping this by small edits..

Hitori

2014-07-03 21:14

viewer   ~~0021232

Em.. What should I do instead? =)

W

2014-07-17 16:44

viewer   ~~0021366

Since upgrading to 1.4r6667, everything is stable, I think that this issue can be closed.

Issue History

Date Modified Username Field Change