View Issue Details

IDProjectCategoryView StatusLast Update
0008283Multi Theft Auto : San AndreasServerpublic2014-06-20 14:11
ReporterarranTunaAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.4 
Summary0008283: [1.4] addVehicleUpgrade doesn't accept strings any more
Description

addVehicleUpgrade(vehicle, "1085") -- Atomic wheels

Used to work. Now it returns false, but it doesn't give a debug warning.

TagsNo tags attached.

Activities

Cazomino05

2014-06-20 10:48

reporter   ~~0021066

that bug count is going up :P

arranTuna

2014-06-20 12:12

manager   ~~0021067

This is actually more of scripter fail but since it's a behaviour change it will break old scripts. It just needs to tonumber any strings.

sbx320

2014-06-20 14:10

administrator   ~~0021070

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6585

Issue History

Date Modified Username Field Change