View Issue Details

IDProjectCategoryView StatusLast Update
0008279Multi Theft Auto : San AndreasServerpublic2014-06-20 12:15
ReporterarranTunaAssigned ToCazomino05 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008279: [1.4] Crashes and ERROR: CPerPlayerEntity problem: m_Players
Description

Sometimes (about 1 in 5) when players quit that message is appearing and also the server crashed when I was using 64 bit but no dump file so I decided to switch to 32 bit to see if that crashes too and maybe if that'll make a dump file so I kicked everyone and the server crashed so I reckon the crashes are related to players disconnecting and this error. I've got 30 people on so it should crash again and hopefully this time there will be a useful dump file.

Got some info when it crashed in event viewer:

Faulting application name: MTAbetaServer.exe, version: 1.4.0.6571, time stamp: 0x53a0e716
Faulting module name: deathmatch.dll, version: 1.4.0.6571, time stamp: 0x53a0e890
Exception code: 0xc0000005
Fault offset: 0x000000000019d196
Faulting process id: 0x11f8
Faulting application start time: 0x01cf8b1db42614ec
Faulting application path: D:\Servers\MTA San Andreas 1.4 Dev\server\MTAbetaServer.exe
Faulting module path: D:\Servers\MTA San Andreas 1.4 Dev\server\x64\deathmatch.dll
Report Id: 9ce45061-f714-11e3-bb45-0025907b011c

Faulting application name: MTAbetaServer.exe, version: 1.4.0.6571, time stamp: 0x53a0e716
Faulting module name: deathmatch.dll, version: 1.4.0.6571, time stamp: 0x53a0e890
Exception code: 0xc0000005
Fault offset: 0x00000000000ee06a
Faulting process id: 0x1298
Faulting application start time: 0x01cf8b215f52df5e
Faulting application path: D:\Servers\MTA San Andreas 1.4 Dev\server\MTAbetaServer.exe
Faulting module path: D:\Servers\MTA San Andreas 1.4 Dev\server\x64\deathmatch.dll
Report Id: 20034c21-f715-11e3-bb45-0025907b011c

TagsNo tags attached.

Activities

Cazomino05

2014-06-18 22:38

reporter   ~~0021052

Last edited: 2014-06-18 22:38

View 2 revisions

both errrors aren't related to per player entities, crash 1 is fixed in:
https://code.google.com/p/mtasa-blue/source/detail?r=6577

Crash 2 is at void CPlayerTextManager::Process ()

Dutchman101

2014-06-18 23:02

updater   ~~0021053

Last edited: 2014-06-18 23:02

View 2 revisions

Are there problems with 64bit server dump generation, also?
If it's crash-specific here, maybe see why it didnt in this case

Cazomino05

2014-06-19 08:09

reporter   ~~0021054

Last edited: 2014-06-19 08:10

View 2 revisions

looks like there are some general issues to do with the way we generate dump files preventing them being created on x64 builds yes Dutchman101

Cazomino05

2014-06-20 12:15

reporter   ~~0021068

crash 2 was fixed by sbx320 in:
https://code.google.com/p/mtasa-blue/source/detail?r=6579

error message in question was deleted due to being misleading in:
https://code.google.com/p/mtasa-blue/source/detail?r=6576

Issue History

Date Modified Username Field Change