View Issue Details

IDProjectCategoryView StatusLast Update
0008232Multi Theft Auto : San AndreasScriptingpublic2014-05-12 12:11
Reportercastillo14Assigned ToJusonex 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008232: [Request] isChatVisible
Description

Well, I would like to suggest to implement a function to see if the chat is currently visible or not, it could be isChatShowing or any other function name.

I don't see a reason for the lack of this function, if there is, I would like to know what is the reason.

TagsNo tags attached.

Activities

Dutchman101

2014-05-11 19:44

updater   ~~0020864

https://wiki.multitheftauto.com/wiki/ShowChat

castillo14

2014-05-11 19:45

viewer   ~~0020865

I'm requesting a function to return if the chat IS visible, not to show/hide it, since there is already one.

Dutchman101

2014-05-11 19:48

updater   ~~0020866

Yeah but on that wiki (ShowChat) in 1 of the example the function isChatVisible is mentioned.

castillo14

2014-05-11 19:51

viewer   ~~0020867

I know this can be done by making one resource control the visibility of the chatbox by exporting the function and storing the state in element data ( so it can be used both client and server side ).

Dutchman101

2014-05-11 20:16

updater   ~~0020868

Yes so then you can solve it by scripting it yourself?

castillo14

2014-05-11 20:18

viewer   ~~0020869

Yes, but I don't see why there shouldn't be a function to check visibility, since there is a isCursorShowing which can also be done by scripting, why wouldn't there be a similar function for the chat box?

Dutchman101

2014-05-11 20:38

updater   ~~0020870

I don't say the function shouldn't be there, but how many other function requests are done, where it's also logically to have the functions?

Then why should yours be prioritized over plenty of other requests with the answer: Script it yourself, ''why should MTA fix it if it's scriptable'' ...

But still in my opinion, the function itself would be usefull, though

castillo14

2014-05-11 20:41

viewer   ~~0020871

I think you're confusing something, because I never asked for priority, I don't even need this function ( not now at least ), I seen a topic on the MTA forums which could have been made easier if a function like this existed, so I decided to suggest it.

P.S: As you can see, I set priority to "low" in the feature report.

Jusonex

2014-05-11 21:31

administrator   ~~0020872

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6407

TAPL

2014-05-12 11:25

viewer   ~~0020874

@Dutchman101, the stored variable or the data won't be accurate as there is MTA hardcoded command "showchat", the variable or the data would be useless if the command was used.

Issue History

Date Modified Username Field Change