View Issue Details

IDProjectCategoryView StatusLast Update
0008215Multi Theft Auto : San AndreasGeneralpublic2018-07-21 17:00
ReporterrafalhAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.4 
Summary0008215: base64Decode cannot handle binary data
Description

Base64 is often used to transfer binary data as plain text. Unfortunately in MTA base64Decode doesn't handle NUL character properly (result is truncated).
Please stop thinking every string in Lua contains no NULs because it's not true.
Story:
I'm trying to add http upload support in my script because #8207 is not fixed. If I try to upload binary data as hidden field in HTML form it's truncated, so I tried base64 and ended in being disappointed by MTA API again...

Steps To Reproduce

assert(base64Decode(base64Encode('\0')) == '\0')

TagsNo tags attached.

Relationships

related to 0008650 closed teaDecode cannot handle binary data 

Activities

Issue History

Date Modified Username Field Change