View Issue Details

IDProjectCategoryView StatusLast Update
0008122Multi Theft Auto : San AndreasClientpublic2014-08-03 16:55
Reportereinheit-101Assigned ToCazomino05 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008122: Projectiles do not hit the target correctly / bounce off their target
Description

Projectiles are able to bounce off their hit position and explode or stick some meters away of their hit position if they fly with a high speed.
Another case: Projectiles do not even reach their target position and explode or stick some meters before they actually hit, those issues may be due to the client`s performance. If you lower the game speed, the projectiles hit correctly, maybe because the client computer is fast enough at lower game speed. I dont know if this is even fixable, but i report it as issue here.

Additional Information

Here is an example Video showing the second variant of this issue. The fired satchels are flying to the wall and do not hit it. But at lower game speed, they come closer to the wall.

https://www.youtube.com/watch?v=MjglBc2BsVw&feature=youtu.be

TagsNo tags attached.

Activities

lopezloo

2014-03-28 21:16

developer   ~~0020491

Last edited: 2014-03-28 21:18

View 2 revisions

Weird bug. That "effect" is smallest on highest FPS (try 100 and 25).

Example code:
createObject(1500, -1, 13, 3)
createProjectile(localPlayer, 39, 0, 0, 4, 1, nil, 0, 0, 0, 0, 1, 0)

IIYAMA12

2014-03-29 12:30

viewer   ~~0020494

Maybe it is to prevent that the projectiles will skip the (hit)element collision.
Which would make sense that the "effect" will be smaller with high fps.

But that is just guessing.

einheit-101

2014-03-29 13:49

reporter   ~~0020496

Yes the performance is important here. With very high FPS (like 100) the Object position is more often updated by MTA. I simulated this effect by reducing the game speed because my Laptop just does not draw more than 40-50 fps.

Cazomino05

2014-07-29 19:04

reporter   ~~0021512

it isn't bouncing back as much as it's not actually applying velocity that last time, what I find most interesting is the physics engine knows where the projectile should be if you take a look at where the sparks end up vs the projectile

Cazomino05

2014-07-29 23:49

reporter   ~~0021519

Thank you for the report, Fixed in r6742
https://code.google.com/p/mtasa-blue/source/detail?r=6742#

einheit-101

2014-07-30 18:48

reporter   ~~0021537

Thx a lot, let me try this. Every fix of my reported issues makes my server a little closer to complete.

Cazomino05

2014-07-30 19:08

reporter   ~~0021540

it should be like spot on position wise ignoring issue #8391 which requires me to offset by the satchel size

einheit-101

2014-08-03 14:43

reporter   ~~0021641

Finally fixed!

Cazomino05

2014-08-03 16:54

reporter   ~~0021643

Last edited: 2014-08-03 16:55

View 2 revisions

should work for reasonable velocities, if you start setting velocities too high with low fps the game will freak out still and go right through solid objects can't do much about that really

so if anyone is reading this and still having this issue just lower your velocity
velocity is a measure of distance over time and I can't see any need for a projectile to move faster than the stream distance per second

Issue History

Date Modified Username Field Change