View Issue Details

IDProjectCategoryView StatusLast Update
0008053Multi Theft Auto : San AndreasClientpublic2015-10-29 14:51
ReporterGallardo9944Assigned Toccw 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows / Linux (Wine)OS Version
Product Version 
Target Version1.5.1Fixed in Version1.5.1 
Summary0008053: Team members are not fully synced clientside when joined
Description

After joining, clientside team members might not be fully synced until they are reset to the team or spawned somewhere in GTA world.

Steps To Reproduce
  1. Draw teams and team members clientside (with DX, for example)
  2. Notice that some players should be in the team
  3. Respawn everyone
  4. All the players are moved to proper teams in the client.
Additional Information

Members should be synced fully by default. This happens in such resources as scoreboard.

TagsNo tags attached.

Activities

arezu

2014-02-16 02:11

viewer   ~~0020230

Indeed, happens in my scoreboard too.

Fabio(GNR)

2014-04-02 18:45

viewer   ~~0020545

related:
createTeam followed by setPlayerTeam will occasionally result in the player being desynced clientside. Clientside he's not in a team, but serverside he is.
Probably because the team wasnt created yet clientside?

Gallardo9944

2014-04-02 19:30

viewer   ~~0020547

Last edited: 2014-04-02 19:30

View 2 revisions

Fabio(GNR), the teams get created, but somehow players are randomly assigned to them. Like half of that might be, half - not.

drifterCZ

2014-04-02 20:02

viewer   ~~0020548

same for ping sync - u see ping 0 for most players when u join and it gets fixed after they respawn

arranTuna

2014-04-02 20:46

manager   ~~0020549

Maybe related to:

http://bugs.mtasa.com/view.php?id=7905#c19855 ?

Fabio(GNR)

2014-04-02 20:47

viewer   ~~0020550

Gallardo, the teams get created but after the client is told to put player X in it. Resulting in no team when you actually do have one.

drifterCZ

2014-04-06 11:21

viewer   ~~0020592

I tested pings and it's definitely related to ped alive. I joined server and saw ping only for players who were alive and the ones who joined just moment before me and hadn't played yet. All dead players had ping 0.

arranTuna

2015-09-14 11:54

manager   ~~0024087

https://github.com/multitheftauto/mtasa-blue/commit/dad962ca70d8cffdabb3bfcbff1572fd8e2d7389

Issue History

Date Modified Username Field Change