View Issue Details

IDProjectCategoryView StatusLast Update
0008020Multi Theft Auto : San AndreasVehiclespublic2014-12-28 06:58
Reportereinheit-101Assigned Toccw 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008020: getVehicleComponentPosition does not function correctly for some components
Description

If i want to get, for example, the position of the “misc_c“ component from Rhinos, i just get a constant value, everytime the same. This makes some things impossible, like finding the world position of the vehicle Muzzle (“misc_c) where the tank bullet is created by GTA. It seems that the returned value of getVehicleComponentPosition is just an relative offset from “misc_b“, the parent of “misc_c“, which explains, why the value never changes, but i am not 100% sure about this. It would be more useful if this function returns the correct world XYZ of the requested component.

Steps To Reproduce

For example,
x,y,z = getVehicleComponentPosition( theVehicle, “misc_c“)
returns the same value everytime, no matter where “misc_c“ really is.

Additional Information

getVehicleComponentPosition does not output any world coordinates, but relative coordinates to the component's parent. If the parent is not the vehicle chassis, the returned value of this function is constant.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 31

2014-03-20 21:45: einheit-101 (EUR 30)
2014-12-19 13:21: AboShanab (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 31)

Activities

ccw

2014-02-11 06:24

administrator   ~~0020187

Please retry with latest nightly

einheit-101

2014-03-11 07:23

reporter   ~~0020355

Last edited: 2014-03-11 07:31

View 2 revisions

I tried now with r06178 and it is still not possible to get the real coordinates of misc_c. It returns:
x = -0
y = 131.44422.....
z = 45.45325.....
for the rhino tank and i tested with swat tank:
x = -0.03479....
y = 2.73427.....
z = 1.65117....

I will try to get some other positions like turret now and maybe they are correct (because the misc_c, the muzzle dummy is a child of misc_a, the turret dummy)

€DIT: It seems to return correct values for turrets, i got always something with
x = 0
y = 0
z = 1.1
and those are correct coordinates relative to the vehicle position (turret is 1 meter above chassis).

einheit-101

2014-07-02 11:46

reporter   ~~0021210

I seriously need the world position of Rhino's misc_c, sponsorship now 30€.

einheit-101

2014-12-19 13:01

reporter   ~~0022702

Issue is fixed in 6974!!! Tested it. Donation incoming.

ccw

2014-12-28 06:58

administrator   ~~0022743

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6980

Issue History

Date Modified Username Field Change