View Issue Details

IDProjectCategoryView StatusLast Update
0008017Multi Theft Auto : San AndreasClientpublic2014-01-30 13:23
ReporterDutchman101Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0008017: Crash on changing GUI skin.
Description

If you change skin (interface) from Default to Lighter Black on 1.3.5-6096, you will get an reproducable crash.

Crash data and dumps below (x2, same reproduction makes 2 different crash dumps & crashinfo's)

Steps To Reproduce
  • Use 1.3.5-6096
  • Start MTA, settings, Interface > have classic skin already set and switch it to Lighter Black and press OK (apply it).
  • Crash.
Additional Information

Version = 1.3.5-release-6096.0.000
Time = Wed Jan 29 00:41:42 2014
Module = C:\Program Files (x86)\MTA San Andreas 1.3\mta\cgui.dll
Code = 0xC0000005
Offset = 0x00065C1A

EAX=DE99D85B EBX=063212F8 ECX=040A0000 EDX=442C8000 ESI=0028FB48
EDI=0028FB88 EBP=0639D728 ESP=0028FB30 EIP=05FB5C1A FLG=00210206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Second (same repoduction though but different crashdata):

Version = 1.3.5-release-6096.0.000
Time = Wed Jan 29 00:43:49 2014
Module = C:\Program Files (x86)\MTA San Andreas 1.3\mta\cgui.dll
Code = 0xC0000005
Offset = 0x00065C18

EAX=00281077 EBX=0644D588 ECX=00000045 EDX=442F8000 ESI=0028FB48
EDI=0028FB88 EBP=0DC43AA8 ESP=0028FB30 EIP=05EC5C18 FLG=00210202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Both dumps attached.

TagsNo tags attached.

Activities

Dutchman101

2014-01-30 08:57

updater   ~~0020101

I can confirm this fixed and cannot reproduce this anymore.

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6099

Issue History

Date Modified Username Field Change