View Issue Details

IDProjectCategoryView StatusLast Update
0008006Multi Theft Auto : San AndreasClientpublic2014-06-14 06:25
ReporterDutchman101Assigned Tosbx320 
PrioritylowSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0008006: [Request] Make an mtasa:// protocol typo handler
Description

Make it so that an typo like [space before mtasa://] on QuickConnect gets resolved to connect anyways.

While copy/pasting an mtasa:// protocol-included server adress it's possible to accidentally copy an space within it.

mtasa://ServerAdress:Port
mtasa://ServerAdress:Port

It now says [Unknown Protocol; Please use the MTA:SA protocol!] [CC71]

Additional Information

Low priority but would be nice to avoid people not being able to connect; it's hard to notice the space typo.

TagsNo tags attached.

Activities

socialz

2014-01-23 21:14

viewer   ~~0020062

Yep. Should probably strip all unwanted characters out and only have the IP and port (with the protocol in front).

sbx320

2014-01-25 15:14

administrator   ~~0020070

Last edited: 2014-01-25 15:17

View 2 revisions

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6093

Stripping out all "unwanted" characters is hard, since you can connect to domain names. However spaces in front of the address are never correct.

socialz

2014-01-27 21:25

viewer   ~~0020087

Last edited: 2014-01-27 21:27

View 2 revisions

Well, it can be hard. However, I made a small test with regexp in PHP. Seems to be working fairly well. Maybe you guys could try to use regular expressions to check for unwanted characters in the wrong spots? I am sure you can split the ip/domain and port with some split function and remove everything else that it finds invalid. Not sure about it really, but I've seen people do that before.

http://socialz.viuhka.fi/preg.php
http://pastebin.com/6AkAMGqb

Dutchman101

2014-01-28 00:52

updater   ~~0020093

Typo's in the plain text of an domain name you can't filter out, but you can make an check whether the domain is resolvable (like mta,gaming.net:22003, as example is invalid)

Issue History

Date Modified Username Field Change