View Issue Details

IDProjectCategoryView StatusLast Update
0007980Multi Theft Auto : San AndreasClientpublic2014-06-14 06:25
ReporterdrifterCZAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007980: MTA doesn't close COL files after replacing collisions
Description

COL file remains open after replacing collision model, until MTA closes

Steps To Reproduce
  1. replace collision model of some object
  2. go to windows explorer and look in local resource folder
  3. Try to delete the collision file
TagsNo tags attached.

Activities

ccw

2014-01-12 03:32

administrator   ~~0019972

Can't reproduce. Example resource please.

drifterCZ

2014-01-13 02:52

viewer   ~~0019978

Last edited: 2014-01-13 02:52

View 2 revisions

It happens when the file is invalid
engineLoadTXD, engineLoadDFF, engineLoadCOL - all these have this problem - when the passed file is invalid, it remains unclosed.
Even when the resource stops, file still cannot be deleted

Example resource: http://driftercz.mtasa.cz/bugs/res.rar

sbx320

2014-01-16 16:20

administrator   ~~0020000

I can't reproduce this with engineLoadCOL. However I found an issue with engineLoadTXD and engineReplaceModel (for DFF files, engineLoadDFF basically just does some small checks).

Could you test this again with a 1.4 nightly from r6071 onwards, please?

http://code.google.com/p/mtasa-blue/source/detail?r=6071

Dutchman101

2014-01-21 18:18

updater   ~~0020030

@sbx320, it is now applied to 1.3.5 (https://code.google.com/p/mtasa-blue/source/detail?r=6075)

@drifterCZ, can you post the results, its still possible to reproduce, or?

CWanted

2014-01-30 17:43

updater   ~~0020107

So was this fixed?

drifterCZ

2014-02-06 01:03

viewer   ~~0020166

OK, I think it's fixed now

Issue History

Date Modified Username Field Change