View Issue Details

IDProjectCategoryView StatusLast Update
0007956Multi Theft Auto : San AndreasVehiclespublic2014-03-29 15:50
ReporterGallardo9944Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSOS Version
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007956: Several vehicle colours result into black ones
Description

Vehicle colours, e.g. 255,60,0 and 255,175,0 make any car black, thus the car has to become orange. Tested with 3 servers, both client and server side scripts, different OSes. It's always reproducable (latest official stable update)

Steps To Reproduce

Create a code (server or client, it doesn't matter) with similar contains:

-- CLIENT SIDE
setVehicleColor(getPedOccupiedVehicle(getLocalPlayer()),255,60,0) -- Of course you have to be in a vehicle to make this work.

-- SERVER SIDE
function onStart()
local vehicles = getElementsByType("vehicle")
for i,v in ipairs(vehicles) do
setVehicleColor(v,255,175,0)
end
end
addEventHandler("onResourceStart",getResourceRootElement(getThisResource()),onStart)

TagsNo tags attached.

Activities

kevenvz

2013-12-31 17:55

viewer   ~~0019895

Last edited: 2013-12-31 17:56

View 2 revisions

I confirm this issue, please fix it!

kakaksk

2014-01-01 09:33

viewer   ~~0019899

Last edited: 2014-01-01 09:34

View 2 revisions

I can only confirm that the 255 175 0 goes to black.I have not tested the others.

ccw

2014-01-02 03:02

administrator   ~~0019902

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6028

Gallardo9944

2014-03-29 15:20

viewer   ~~0020497

Last edited: 2014-03-29 15:50

View 2 revisions

r6257 + the latest stable MTA in-game update (can't really say which build it is), the issue is reproducable exactly the same way. Example: 60,255,0 is blacked out.

Issue History

Date Modified Username Field Change