View Issue Details

IDProjectCategoryView StatusLast Update
0007954Multi Theft Auto : San AndreasClientpublic2014-06-14 06:25
ReporterRen712Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007954: Ped attached objects slide when ped walks on slopes.
Description

getPedBonePosition function always returns proper values.
Drawing an image with xyz coords passed by getScreenFromWorldPosition
also works properly. But somehow attached to ped elements will have
incorrect positions when the ped is walking on a sloped surface

http://www.youtube.com/watch?v=qQ81IsjnB8Q

I thought this was bone_attach resource issue. Run example script
i have attached to this report to recreate the issue.

Steps To Reproduce

1.Attach object to ped bone or ped
2.Walk up or down a hill

TagsNo tags attached.

Relationships

has duplicate 0005829 closed New issues Wrong bone positions when walking on a slope 

Activities

Ren712

2013-12-30 22:24

viewer   ~~0019892

This is nothing new apparently http://bugs.mtasa.com/view.php?id=5829

Ren712

2014-01-15 02:05

viewer   ~~0019990

Last edited: 2014-01-15 02:09

View 2 revisions

It doesn't seem to happen on every surface. The ped seems to be animated in a different way (moves back a bit) when this bug occurs.

https://www.youtube.com/watch?v=cpHSsllTNsc

Also the script i used:
http://www.solidfiles.com/d/c9f3b2d1c2/

Ren712

2014-01-15 21:27

viewer   ~~0019994

CrystalMV sent me this:
getPedBonePosition is exactly what's wrong about it. onClientPreRender event seems to be triggered before the pose of ped is adjusted to make the effect of walking on a slope, so calling the function returns the wrong position.?

qaisjp

2014-01-15 22:17

administrator   ~~0019995

A workaround for now is to update that specific position in onRender.

lopezloo

2014-01-16 14:11

developer   ~~0019998

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6069

Issue History

Date Modified Username Field Change