View Issue Details

IDProjectCategoryView StatusLast Update
0007919Multi Theft Auto : San AndreasMulti Theft Auto : San Andreaspublic2013-12-03 02:54
ReporterkakakskAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8.1 64-bit
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007919: Player cannot walk sideways while aiming with latency_reduction enabled
Description

If you stop in a fixed position and hold your aiming, you will notice that you won't be able to move sideways (left and right) from the position. That always requires pressing forwards or backwards to start moving sideways and consumes time. Can be reproduced only when the latancy_reduction setting is set to true.

Steps To Reproduce
  1. Set your latency_reduction in mtaserver.conf to true
  2. Stand in a fixed position
  3. Aim your weapon
  4. Hold "left" or "right" control
  5. The player won't be moving
Additional Information

Latencry reduction clearly says that it should affect only remote players. So why in this case the local player is affected?

TagsNo tags attached.

Activities

Jusonex

2013-12-02 15:46

administrator   ~~0019744

What's the difference between this issue and https://bugs.mtasa.com/view.php?id=7915 ?

arranTuna

2013-12-02 15:53

manager   ~~0019745

Only difference is: "Set your latency_reduction in mtaserver.conf to true"

Which doesn't make sense because #4291 was reported way before latency_reduction was added.

kakaksk

2013-12-02 23:20

viewer   ~~0019747

It makes sense because without latency reduction the bug doesn't occur at 60 fps while with the setting on it does.

ccw

2013-12-03 02:14

administrator   ~~0019748

Last edited: 2013-12-03 02:54

View 3 revisions

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5965

Issue History

Date Modified Username Field Change