View Issue Details

IDProjectCategoryView StatusLast Update
0007908Multi Theft Auto : San AndreasMulti Theft Auto : San Andreaspublic2014-02-16 06:03
ReporterkakakskAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8 64-bit
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007908: Cannot enter any vehicle after trying to enter a vehicle in water
Description

Cannot enter any vehicle in water. If you press enter, nothing happens. After this, any other vehicle cannot be entered too.

Steps To Reproduce
  1. Spawn a seasparrow on normal water.
  2. Press enter to enter the vehicle.
  3. Nothing happens.
  4. After this, any other vehicle cannot be entered, no matter, if it is in water or not.
TagsNo tags attached.

Relationships

related to 0004246 closed Multi Theft Auto : San Andreas Vehicle entry bug in skimmer/seasparrow/leviathon etc 
has duplicate 0007940 closed New issues Cannot enter any vehicle, if ped is swimming 

Activities

kakaksk

2013-11-24 11:04

viewer   ~~0019702

Is that intended?

ccw

2013-11-24 11:33

administrator   ~~0019703

No
Is it only the seasparrow?

kakaksk

2013-11-24 17:55

viewer   ~~0019705

Last edited: 2013-11-24 17:59

View 2 revisions

Also for leviathan, skimmer, vortex. All the floating vehicles, which must be entered from water (not like in the boats, where you have a surface).

kakaksk

2013-11-25 12:39

viewer   ~~0019710

Any info?

arranTuna

2013-11-25 14:53

manager   ~~0019711

You don't even need to be in the water, just the vehicle to reproduce this bug.

Cazomino05

2013-11-25 15:46

reporter   ~~0019712

someones been messing with my vehicle entry code again >:(

kakaksk

2013-11-25 16:28

viewer   ~~0019713

Not really, arranTuna. For example, if i try to enter the leviathan without contacting the water, everything works fine. But only if you have not tried to enter the vehicle before trying to enter it whwn contacting the water.

kakaksk

2013-12-20 15:42

viewer   ~~0019816

Is this one moving or not?

asturel

2014-01-14 01:02

reporter   ~~0019985

Last edited: 2014-01-14 01:05

View 2 revisions

client: Multi Theft Auto v1.3.4-release-6046
server MTA:SA Server v1.3.5-release-6060

If the player tries to enter it wont enter, but getPedOccupiedVehicle will return the vehicle (instead of false), also if you manually warp the ped into it, he will show as 'network troubled' player and stucked on remote players, but actually he can move around and hit/kill ppl

ps: the seasparrow was on the water and the player was in the water

kakaksk

2014-02-15 18:33

viewer   ~~0020222

Still reproducible having both server and client at 1.3.5-9.06121.0. Is this going to move?

Dutchman101

2014-02-15 21:07

updater   ~~0020224

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6140

ccw

2014-02-16 06:03

administrator   ~~0020233

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6140

Issue History

Date Modified Username Field Change