View Issue Details

IDProjectCategoryView StatusLast Update
0007897Multi Theft Auto : San AndreasServerpublic2014-06-14 06:25
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007897: [Request] Responsible resource parameter in onElementDestroy
Description

As element IDs are reused and every scripter didn't know this, we've been making scripts that don't properly handle elements being destroyed like elements in tables or elements in a timer.

If onElementDestroy had a responsible resource parameter we can compare the resource that destroyed it to the resource that created it and if they differ it means we'd find the scripts that are destroying elements of other resources and then we can fix them.

Or any other way to detect these bad scripts would be fine.

TagsNo tags attached.

Activities

qaisjp

2013-11-11 21:41

administrator   ~~0019648

Appropriate wrappers and/or a method of elimination can be used to determine rogue scripts. But I agree with the suggestion.

arranTuna

2013-11-24 22:37

manager   ~~0019708

Turns out this has existed in secret for a month

http://code.google.com/p/mtasa-blue/source/detail?r=5902

I request a forwardport so that it will always exist.

ccw

2013-12-02 00:21

administrator   ~~0019742

sourceResource is now fixed for events. Are there any circumstances where the resource argument in the secret test code differs from sourceResource ?

arranTuna

2013-12-02 20:34

manager   ~~0019746

Last edited: 2013-12-02 20:46

View 3 revisions

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5937

Issue History

Date Modified Username Field Change