View Issue Details

IDProjectCategoryView StatusLast Update
0007860Multi Theft Auto : San AndreasClientpublic2014-09-02 11:29
ReporterkakakskAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8 64-bit
Product Version 
Target VersionFixed in Version1.4.1 
Summary0007860: Jetpack sound remains when it's removed in certain conditions
Description

If you die carrying a jetpack, the sound of jetpack thrusters will be stuck after respawning, so you keep hearing the thrusters even if not on jetpack.

Steps To Reproduce
  1. Take a jetpack
  2. Die
  3. Respawn
  4. Now you will see that the sound of jetpack is being stuck.
TagsNo tags attached.

Relationships

has duplicate 0008468 closed New issues Jetpack sound still plays after death 

Activities

JBoy

2013-10-16 15:25

viewer   ~~0019507

Did you try putting the jetpack back on and taking it off again? Think this worked once for me a while back..

kakaksk

2013-10-16 20:14

viewer   ~~0019508

It did. But everytime giving and removing a jetpack looks pretty weird for remote clients.

JBoy

2013-10-16 23:16

viewer   ~~0019509

try removing the players jetpack when they die (or before they die), see if that'll stop the sound bug.

kakaksk

2013-10-17 07:11

viewer   ~~0019510

It doesn't. The jetpack is removed before they are killed. You must give a new jetpack and then remove to fix the stuck sound.

arranTuna

2013-12-21 18:12

manager   ~~0019829

Unable to reproduce in v1.4-unstable-6006

The jetpack sound disappeared when I respawned, but the sound remained after it was automatically removed on death until the camera moves away or you respawn.

Grafu

2014-08-18 22:26

viewer   ~~0021798

Too lazy too reproduce*

I reproduced this myself on 1.4 r6805

http://youtu.be/fPLWxHQG8h8

The sentence you said only confused away the issue to the trash.

arranTuna

2014-08-18 23:06

manager   ~~0021799

Unable to reproduce still.

Multi Theft Auto v1.4-release-6812.3

Go on local server with just play and freeroam

/jetpack

/kill

No sound after respawn. So whatever game mode you're on is causing an issue.

I'm so "lazy" I actually bother to test things in a testing environment. Play and freeroam is the real place to test stuff, not on a server with 200 scripts that could be conflicting.

Woovie

2014-08-18 23:09

manager   ~~0021800

I can confirm Arran's findings to be identical with mine. Running play resource, I experience no issue on r6812.

lopezloo

2014-08-18 23:43

developer   ~~0021801

Last edited: 2014-08-18 23:46

View 3 revisions

@Arran, Woovie
You guys need to spawn near position when you died.

This can also be reproduced without dying. Example steps to reproduce:

  1. Get jetpack and go to position near 0,0,0
  2. run spawnPlayer(getRandomPlayer(), 0, 0, 5)

Woovie

2014-08-19 00:09

manager   ~~0021803

Last edited: 2014-08-19 00:09

View 2 revisions

I did spawn near where I died and it still cleaned up. I will test it further though.

Grafu

2014-08-19 11:46

viewer   ~~0021805

That's why:

run givePedJetPack(getPlayerFromName("player"))
run setElementHealth(getPlayerFromName("player"), 0) --Removes the jetpack sound
run killPed(getPlayerFromName("player")) --Keeps the sound

lopezloo

2014-08-21 09:29

developer   ~~0021826

Last edited: 2014-08-21 09:29

View 2 revisions

Same with applying animations which remove jetpack.
run givePedJetPack(getRandomPlayer())
run setPedAnimation(getRandomPlayer(), "biked", "biked_passenger")

arranTuna

2014-08-21 17:41

manager   ~~0021827

Can reproduce it with the animation but with killPed the sound was removed.

MrTasty

2014-08-21 17:59

viewer   ~~0021828

Reproduced on Multi Theft Auto v1.4-r6812

Test on a default server but turn off 'play' - make sure freeroam is on:
/jetpack
/kill
/setpos (spawns player in same position if no arguments passed)

Sound wasn't removed for me

Grafu

2014-08-21 21:22

viewer   ~~0021829

Seriously? Sound gets removed right after /kill for me, when /kill executes setElementHealth(player, 0). But the sound doesn't get removed, if using killPed(player).

sbx320

2014-09-01 01:36

administrator   ~~0021899

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6840

StifflersMom

2014-09-02 11:29

updater   ~~0021918

Hm. One more (v1.4-release-6843):

  1. take a jetpack,
  2. srun setElementFrozen(getRandomPlayer(),true)

(jetpack is removed, sound remains)

Issue History

Date Modified Username Field Change