View Issue Details

IDProjectCategoryView StatusLast Update
0007837Multi Theft Auto : San AndreasMulti Theft Auto : San Andreaspublic2013-11-11 15:04
ReporterkakakskAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 8OS Version64-bit
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007837: "unknown" name for scripts without cache saving
Description

If you define cache to false for the clientside scripts in the meta.xml, the output debug messages will be unknown and won't provide enough info.

TagsNo tags attached.

Activities

JBoy

2013-09-26 17:07

viewer   ~~0019390

This is because the script is not being saved to the hard drive and so the debug can't find what client script it is.

arranTuna

2013-09-26 18:23

manager   ~~0019391

It worked before though, there was a change to protected client scripts that caused this, though it's fairly redundant now since AFAIK the luac.mtasa.com can protect them more.

CWanted

2013-09-27 17:00

updater   ~~0019400

https://code.google.com/p/mtasa-blue/source/detail?r=5845
https://code.google.com/p/mtasa-blue/source/detail?r=5848

kakaksk

2013-09-29 11:55

viewer   ~~0019407

Well, updated my client and server, but I am still getting (unknown) type messages.

ccw

2013-09-29 22:35

administrator   ~~0019410

Please try with a compiled script

kakaksk

2013-09-30 21:10

viewer   ~~0019427

I am trying with a normal (not encrypted) client script without cache and I get unknown

kakaksk

2013-10-01 06:59

viewer   ~~0019428

And the script files are encoded in UTF-8 without BOM

Dutchman101

2013-10-02 02:29

updater   ~~0019432

@kakaksk, go to luac.mtasa.com, and compile them, then try again.

Kenix

2013-10-02 17:36

updater   ~~0019435

Last edited: 2013-10-02 17:37

View 2 revisions

I got this problem too on newest version of MTA.
All scripts is not compiled.

kakaksk

2013-10-03 15:35

viewer   ~~0019437

@Dutchman101 I want them editable

Dutchman101

2013-10-04 17:04

updater   ~~0019443

@kakaksk, until this is fixed, you could use an lua.bak to edit and (re)compile them.

kakaksk

2013-11-11 08:51

viewer   ~~0019646

Last edited: 2013-11-11 08:52

View 2 revisions

This is after the fix and compilation:

WARNING: client.lua:128: Bad argument @ 'attachElements'

Still missing for the file path and also argument number (?)

I have thousands of client.lua. How do I know which one is it?

arranTuna

2013-11-11 15:04

manager   ~~0019647

Which is why scripters should never use generic file names.

Issue History

Date Modified Username Field Change