View Issue Details

IDProjectCategoryView StatusLast Update
0007829Multi Theft Auto : San AndreasServerpublic2013-10-01 16:25
ReporterJBoyAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007829: killPlayer crashes server
Description

using killPlayer(getRootElement()) causes the server to crash. Have been able to reproduce 3 times now and have tried with the updated files.

Steps To Reproduce

/srun killPlayer(getRootElement())
-> Crash.

TagsNo tags attached.

Activities

JBoy

2013-09-21 04:06

viewer   ~~0019362

Server version: MTA:SA Server v1.3.4-release-5800

ccw

2013-09-21 04:34

administrator   ~~0019363

Can't reproduce this.
If it's a windows server, please upload latest file from server\dumps\public

JBoy

2013-09-21 12:01

viewer   ~~0019364

its on Linux :\

lopezloo

2013-09-21 13:16

developer   ~~0019365

killPlayer() is deprecated. Use killPed().

ccw

2013-09-22 01:12

administrator   ~~0019375

For Linux, there might be some crash info in 'dumps' directory

JBoy

2013-09-23 14:36

viewer   ~~0019385

Re-tested with killPed, same thing occured.

Crash log (from dump):
http://pastebin.com/haTUC6Xa

CWanted

2013-09-25 10:12

updater   ~~0019389

https://code.google.com/p/mtasa-blue/source/detail?r=5839

Issue History

Date Modified Username Field Change