View Issue Details

IDProjectCategoryView StatusLast Update
0007799Multi Theft Auto : San AndreasServerpublic2013-10-19 10:08
ReporterPawnsuAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSUbuntuOS Version13
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007799: Server screenlog format
Description

Hi

If I start the server with screen and option -t, and also with screenlog, I get in the log much lines like:
?[23B?[m??[39;49m?[37m?[40m?[H?[C?[0;1m??[34m?[47m-...

And this log format comes again and again so the log file is oversized...

Steps To Reproduce

start mta-server on linux server with the screen command and option -L and see the screenlog

Additional Information

I have attached the screenlog file

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 100

2013-09-01 09:48: Pawnsu (EUR 100)
Users sponsoring this issue (Total Sponsorship = EUR 100)

Activities

ccw

2013-08-31 02:57

administrator   ~~0019238

Does launching MTA server with -t option help?

Pawnsu

2013-08-31 22:16

viewer   ~~0019244

No, it doesn't

Dutchman101

2013-09-10 06:21

updater   ~~0019300

I tried to reproduce this on Windows server, and it doesn't happen.
So it's linux dependent.

mickdermack

2013-09-13 22:54

viewer   ~~0019321

This seems to be caused by the ncurses library sending terminal control codes that would set the position of the cursor, colors, etc. in a terminal, but if written to a file it causes the file to lose quite a bit of its readability.
There should be a way to disable ncurses altogether (what about a switch "--nocurses", or "-t -t"/"-tt"?) and let MTA disable ncurses automatically if stdout isn't a terminal, although that seems to be a not-quite-trivial thing since every kind of in- and output seems to be implemented via ncurses under Linux, but let's wait for a dev.

dvarnai

2013-09-28 21:37

viewer   ~~0019405

Last edited: 2013-09-28 23:40

View 2 revisions

ive finished adding a startup paramater to disable the use of ncurses completely. sorry im not too familiar with mantis but heres the patch:

http://pastebin.com/ChKAMXtK

usage:

./mta-server -n

proof:

http://i.imgur.com/UUH3xgr.jpg

gnu screen on the right and screenlog shown inside my control panel on the left.

in case anyone wants the compiled binaries or just want to say thanks feel free to email me: dvarnai at gmail.com

ccw

2013-09-29 22:49

administrator   ~~0019412

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5849

Kernell

2013-10-04 16:06

reporter   ~~0019442

Fixed, but there was a new bug: Backspace key does not work. I can't remove previuos character from input.

Server: openSUSE 12.3
MTA: 1.3.4-release-5858
command line: screen -dmS mtarp /var/games/mtarp/mta-server -n

Kernell

2013-10-19 10:08

reporter   ~~0019515

up

Issue History

Date Modified Username Field Change