View Issue Details

IDProjectCategoryView StatusLast Update
0007794Multi Theft Auto : San AndreasClientpublic2013-09-05 02:04
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.4Fixed in Version1.3.4 
Summary0007794: Bad debug from encrypted client scripts
Description

Encrypted client scripts have debug disabled and any errors will not come up. However debug warnings from MTA functions still do, but without any useful information whatsoever meaning that if a script was spamming warnings there would be no way of finding where its coming from because the messages are like this:

"WARNING: Bad argument @ 'destroyElement' ?"

I propose that if there is no resource name, file name or script line in a debug output (like above) then the debug should not be output as the above debug warning will cause nothing but frustration.

Steps To Reproduce

Make a script file with something like destroyElement(false) in it and run it through luac.mtasa.com

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change