View Issue Details

IDProjectCategoryView StatusLast Update
0007787Multi Theft Auto : San AndreasMap Editorpublic2013-09-02 10:37
ReporterEt-winAssigned Toccw 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.4Fixed in Version1.3.4 
Summary0007787: Map Editor crashes after pressing "Stop Testing"
Description

If you are testing your map and you press 'F1' and then "Stop Testing", then MTA crashes. Not always, but mostly it does. (I guess 90% change for the crash)

Additional Information

Version = 1.3.3-release-5722.0.000
Time = Mon Aug 26 20:18:51 2013
Module = E:\Program Files (x86)\Rockstar Games\Multi Theft Auto San Andreas 1.3\mods\deathmatch\lua5.1.dll
Code = 0xC0000005
Offset = 0x000160CB

EAX=29AC19E0 EBX=0EB2F728 ECX=0EB2F7A0 EDX=29A52130 ESI=0EB2F728
EDI=29A52130 EBP=1B4DEEBC ESP=1B4DEDB0 EIP=0F3160CB FLG=00010202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

TagsNo tags attached.

Activities

tinostar91

2013-08-26 22:19

viewer   ~~0019206

I actually was able to reproduce crash but it wasn't on first try and it was caused by something different, for me it's always 16th try of "Stop Testing" no matter how fast you are

Version = 1.3.3-release-5722.0.000
Time = Mon Aug 26 22:05:39 2013
Module = E:\Hry\Rockstar Games\GTA San Andreas\proxy_sa.exe
Code = 0xC0000005
Offset = 0x00133606

EAX=00000000 EBX=00000075 ECX=04747D08 EDX=1B8A17C0 ESI=00B839A0
EDI=0000001B EBP=1B9556B0 ESP=0028F7D8 EIP=00533606 FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Video if you want (fraps will not capture crash) - http://youtu.be/riDOL4jCbH8

ccw

2013-08-27 04:04

administrator   ~~0019208

tinostar91, your crash is different (related to building removal) and should be fixed in the latest nightly: http://nightly.mtasa.com/?mtasa-1.3.4-rc-latest

BieHDC

2013-08-27 16:01

viewer   ~~0019211

for me it happens most time when i do race full test

now i always test the map itself with none full test and set the vehicle which is spawnpoint

ccw

2013-08-29 20:25

administrator   ~~0019225

Please try latest nightly:
http://nightly.mtasa.com/?mtasa-1.3.4-rc-latest

Et-win

2013-08-29 21:59

viewer   ~~0019228

I have installed the lasted Nightly, but it keeps crashing everytime, sadly.

ccw

2013-08-30 07:11

administrator   ~~0019231

I can't reproduce the crash here. Can you give exact steps using a brand new install of MTA. (Make another install to a new directory)

Et-win

2013-08-30 12:33

viewer   ~~0019232

I have completely deleted and removed MTA out of my computer. I have installed the original MTA from www.mtasa.com and I started it up. I started the Map Editor. I added the gamemode "race" into my Definations and Map Settings and placed a spawnpoint. I press "Start Testing" and some seconds later (After I spawned) I pressed "F1" and "Stop Testing" and immediately the game closed and I get the same error. Tried it serveral times but I keep getting this error.

ccw

2013-08-31 04:07

administrator   ~~0019240

Another patch to try:
http://nightly.mtasa.com/?mtasa-1.3.4-rc-latest

Et-win

2013-08-31 10:02

viewer   ~~0019241

Sorry, but after installing this Nightly it still keeps crashing. :(

ccw

2013-08-31 23:34

administrator   ~~0019245

And another one:
http://nightly.mtasa.com/?mtasa-1.3.4-rc-latest

Et-win

2013-09-02 00:27

viewer   ~~0019260

I'm sorry for the late reply. Anyway, now if I press "Full Test" and as soon as the gamemode "Race" has been downloaded it has to start it and spawn me, but instead of this it just crashes now.

Error:

Version = 1.3.4-release-5782.0.000
Time = Mon Sep 02 00:26:31 2013
Module = E:\Program Files (x86)\Rockstar Games\Multi Theft Auto San Andreas 1.3\server\mods\deathmatch\deathmatch.dll
Code = 0xC0000005
Offset = 0x000E76C0

EAX=00000000 EBX=113EE380 ECX=0000007A EDX=2ADC32C0 ESI=00000000
EDI=2C68BA88 EBP=1BC0F16C ESP=1BC0F07C EIP=1C0076C0 FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

ccw

2013-09-02 03:40

administrator   ~~0019262

Ok, that crash has been fixed.
Please try latest nightly again:
http://nightly.mtasa.com/?mtasa-1.3.4-rc-latest

Cazomino05

2013-09-02 04:55

reporter   ~~0019263

Last edited: 2013-09-02 04:55

View 2 revisions

the crash was unrelated it was me fixing something totally different just happened to start while this bug report was going on (but if you update your server it's fixed)

Et-win

2013-09-02 09:42

viewer   ~~0019266

The Map Editor works fine again, thanks for the updates! :)

Issue History

Date Modified Username Field Change