View Issue Details

IDProjectCategoryView StatusLast Update
0007740Multi Theft Auto : San AndreasClientpublic2013-12-25 11:51
ReporterarranTunaAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007740: [Sync] Sometimes moving when aiming isn't synced
Description

Sometimes a player who aims a slow moving gun like deagle or SPAS will be seen as sliding rather than have their feet moving, all the people I've seen it happen to are CJ's (If I remember correctly) so it might be something to do with that.

I recorded a video with the players tasks on screen too. He was sliding around when shooting with deagle, I then crashed and when I came back and spectated him again he was normal:

http://youtu.be/bgVMNq8-CSA

Maybe it's not actually sync that's a problem maybe for some reason the foot animation just fails to work. Since it shows him moving smoothly which suggests that keysync is telling us that he's moving but for some reason not animating his feet.

TagsNo tags attached.

Relationships

related to 0007905 resolvedsbx320 setPedStat sometimes not synced to client 

Activities

arranTuna

2013-11-23 19:50

manager   ~~0019701

Last edited: 2013-11-23 19:55

View 2 revisions

Oh, I just realised why this happens.

Because their stat is desynced, they're using default skill level on your client, which cannot move and shoot so instead they slide:

http://bugs.mtasa.com/view.php?id=7905

arranTuna

2013-12-25 11:50

manager   ~~0019863

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6016

Issue History

Date Modified Username Field Change