View Issue Details

IDProjectCategoryView StatusLast Update
0007702Multi Theft Auto : San AndreasClientpublic2014-02-25 16:01
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007702: exports: Call to non-running client resource (name) [string "?"]
Description

Because client resources all start at different times it is too easy for one resource to try and call another resource before the other resource has started. The debug error that is returned is not helpful at finding the calling resource.

If [string "?"] was turned into the name of the resource that is trying to call it, that would help a lot.

TagsNo tags attached.

Relationships

has duplicate 0006821 closed New issues Unclear error message calling exported functions of none running resources 

Activities

Fabio(GNR)

2013-08-30 20:57

viewer   ~~0019237

In general, the info provided could be improved.
The message you get when a function doesn't exist isn't very specific/correct.

Fabio(GNR)

2014-02-01 16:17

viewer   ~~0020131

Last edited: 2014-02-01 22:29

View 3 revisions

bump, also
"ERROR: attempt to call a nil value"
"ERROR: call: failed to call 'bla:funcbla'" [string "?"]
is not helpful and bothers me every day :(

EDIT:
found out the issue is due to exports.res:func method,
because that's some sort of MTA hack ( i have no clue ), the scriptdebugger can't find the actual source of the call. Leading to an empty file and empty line,
not sure how this can be fixed but it involves changing the exports.res:func method.

It's a Lua script being loaded in to every environment, since it's local it wont get found by the scriptdebugger. I, however, have no solution to this.

Fabio(GNR)

2014-02-02 14:21

viewer   ~~0020141

Last edited: 2014-02-02 14:55

View 2 revisions

Got a patch:
https://www.dropbox.com/s/6yoxtjis3js55v6/export-debugging-0007702.patch
If the source file and line are not found, it goes up a stack. ( this is limited to one time, so if level 1 ( default ) is not found, it checks level 2 )
Tested and it worked :o

Fabio(GNR)

2014-02-25 14:37

viewer   ~~0020264

Last edited: 2014-02-25 14:40

View 2 revisions

This appears to have been fixed in 1.3.5?

patch was applied https://code.google.com/p/mtasa-blue/source/detail?r=6124

Issue History

Date Modified Username Field Change