View Issue Details

IDProjectCategoryView StatusLast Update
0007672Multi Theft Auto : San AndreasClientpublic2013-08-14 15:46
ReporterkakakskAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version8
Product Version 
Target Version1.3.4Fixed in Version1.3.4 
Summary0007672: Mouse input delayed
Description

Installed nightly r5555 and noticed that the build started lagging. Earlier I could prevent the lag corpses by unchecking "Disable Aero desktop". After the installation of the nightly build it doesn't work anymore. Whenever you check it or not, you can feel lag corpses. I guess, it's only Windows 8 issue.

Steps To Reproduce
  1. Play MTA
TagsNo tags attached.

Activities

ccw

2013-06-26 00:50

administrator   ~~0018827

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5567

SHC//Sniper

2013-06-26 19:28

reporter   ~~0018829

Still an issue for me on Windows 8 in r5571, lag spikes every 5-10 seconds, no matter what settings are being used (Driver Overrides setting included).

LooooP

2013-06-26 22:39

reporter   ~~0018830

Last edited: 2013-06-26 22:39

View 2 revisions

I'm also having some FPS drops, but they are rare (happens 1 time a day), FPS drops from 49 (limit) to ~ 20 and then goes to 49 again, tried with and without the Driver Override setting
DxDiag: http://pastebin.com/9UkpwN9E

ccw

2013-06-26 22:53

administrator   ~~0018831

Last edited: 2013-06-26 23:03

View 2 revisions

We don't accept lag spikes or FPS drops as useful descriptions anymore.
Sorry.

Make a video with 'showframegraph 1'

LooooP

2013-06-27 04:43

reporter   ~~0018832

Screen showing showframegraph 1 while there were some smaller, but more frequent FPS drops (to ~ 40 FPS): http://i.imgur.com/dFtjiKK.jpg

ccw

2013-06-27 05:11

administrator   ~~0018833

Need to see a video if possible. Remove d3d9.dll when you do that, thanks.

SHC//Sniper

2013-06-27 22:09

reporter   ~~0018836

Last edited: 2013-06-27 22:10

View 2 revisions

Seems like I am facing a different problem with FPS drops from LooooP. For me the drops can't actually be seen in the FPS counter or framegraph (http://i.imgur.com/fasYwrF.png), though I can clearly "feel" significantly lower framerates (25-30 fps) every 5-10 seconds for about 1-2 seconds. The problem might somehow be related to the FFS server.

P.S.: Hard to record those FPS drops as YouTube only allows up to 30 FPS, will try to find another way to send you raw video data.

MTADiag: http://pastebin.mtasa.com/324753116

LooooP

2013-06-29 00:41

reporter   ~~0018838

Last edited: 2013-07-05 23:19

View 3 revisions

@ccw: https://mega.co.nz/#!GZFggSqI!MmHY0CpMmrmrDFbXRS5r8lDJw6sssEAU8TlcZiCLKvs

Was having smaller FPS drops (from 49 to ~ 35)

EDIT: Added download link to the video because on YouTube you can't notice the FPS drops very well

Max_Taylor

2013-06-29 00:55

viewer   ~~0018839

Install this: http://www.microsoft.com/hu-hu/download/details.aspx?id=30653

Will be better.

LooooP

2013-06-29 23:32

reporter   ~~0018840

I have it installed

kakaksk

2013-06-30 15:50

viewer   ~~0018841

Well same problem as Sniper's. My fps meter shows 59-60 fps, but when playing it feels like it was 20-25, simillar to the lag, which is caused when your HDD is being almost full. Ive faced same problem earlier when changing the setting "disable aero desktop", so it might be related to it.

ccw

2013-07-06 04:30

administrator   ~~0018869

Loooop, go here: mtasa://46.105.46.97:22103
type 'freecam' command and fly around.
Do you still get spikes on showframegraph ?

kakaksk

2013-08-14 15:46

viewer   ~~0019141

well, i recently played my own server. Fps drops from 60 to 5 every 5-10 seconds. The lag takes just some ms.

Issue History

Date Modified Username Field Change