View Issue Details

IDProjectCategoryView StatusLast Update
0007658Multi Theft Auto : San AndreasClientpublic2013-07-08 22:28
ReporterDutchman101Assigned Toccw 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWin7 x64OS Version
Product Version 
Target Version1.3.3Fixed in Version1.3.3 
Summary0007658: 1.3.3 nightly disconnects from servers and times out randomly
Description

When using 1.3.3 nightly (r5527 and previous) it will randomly disconnect from servers, it's random and differ from normal crash: It'll appear if like the server 's host crashed, since most of the time if times out, and you'll still be able to connect to other servers, but the crashed one wont be able to connect in some time. Restarting MTA usually helps.

  • It always starts with lagging, like the pings in TAB freeze, and sometimes it'll recover, other times it will crash in the way stated above.

It happened on different PC's for me.I downgraded to 1.3.2 r5499, which doesn't have this problems.

TagsNo tags attached.

Activities

ccw

2013-06-15 12:35

administrator   ~~0018751

Which servers were you connected to when you had these problems?

Dutchman101

2013-06-15 16:32

updater   ~~0018759

Last edited: 2013-06-15 16:34

MTA:RP(server r4943), Mini-Missions (server r5503)

But it has nothing to do which servers you're connected to I think, because it happens to different servers, on different PC's (where im not at, so i cant look in recent servers there)

Edit: It also seems that i managed to fix it by downgrading to r5499 1.3.2,
but when i updated to r5503, it started to happen again, but not as much as on r5527 and previous. So it may have to do with a change from revision r5499 to r5503, just a guess.

ccw

2013-06-15 19:16

administrator   ~~0018760

The client did not change between 5499 and 5503, so please double check

Dutchman101

2013-06-15 19:52

updater   ~~0018761

I see, the issue seems to have occured from the first time I downloaded a 1.3.3 nightly (when it was released) but still no clue why it stopped when i downgraded

In clientscript: ERROR: ?:0: attempt to compare boolean with number
shows up alot, while using 1.3.3, not happening on 1.3.2 r5499.

ccw

2013-06-16 00:36

administrator   ~~0018766

Please try latest nightly: http://nightly.mtasa.com/?mtasa-1.3.3-rc-latest

Dutchman101

2013-06-16 00:50

updater   ~~0018767

Will do tomorrow, thanks.

ccw

2013-06-16 23:23

administrator   ~~0018770

Last edited: 2013-06-16 23:36

View 2 revisions

<Dutchman101> Thanks, it got fixed on latest r5537!

LooooP

2013-07-06 00:12

reporter   ~~0018867

Doesn't seems fixed: http://youtu.be/-2urJRSUCug

Client: MTA:SA 1.3.3 r5588
FFS: MTA:SA 1.3.3 r5575
EPG: MTA:SA 1.3.1 r4710
TG: MTA:SA 1.3.2 r5518
Terra: MTA:SA 1.3.3 r5584

ccw

2013-07-06 04:28

administrator   ~~0018868

When did it first start happening?
(Don't just say 1.3.3)

LooooP

2013-07-06 05:27

reporter   ~~0018870

Last edited: 2013-07-06 05:41

View 2 revisions

I can't remember really :/
But it already happend in 1.3.2

Dutchman101

2013-07-08 22:28

updater   ~~0018881

You're right, it seemed fixed, but it's still happening for me.
It really is quoted from myself: It'll appear if like the server 's host crashed, since most of the time if times out, and you'll still be able to connect to other servers, but the crashed one wont be able to connect in some time. Restarting MTA usually helps.

Like this, yes. And I think it started happening on late 1.3.2 builds.
I still have this problem, no idea where it comes from..
Sometimes it will just happen to be lag and network trouble and the game can recover from it, but most of the time it simply times out.

Issue History

Date Modified Username Field Change