View Issue Details

IDProjectCategoryView StatusLast Update
0007620Multi Theft Auto : San AndreasClientpublic2014-07-01 22:35
ReporterkakakskAssigned ToCazomino05 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version8
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007620: Hydra keeps loosing velocity in the air
Description

Hydra keeps losing velocity in the air. I have used setAircraftMaxVelocity on resource start. Havent tried, if the same issue is without it. Also vehicle extrapolation setting is on. The bug appears randomly (mostly when many players are around).

TagsNo tags attached.

Relationships

related to 0007916 resolvedsbx320 Changing skin resets vehicle velocity 

Activities

arranTuna

2013-05-10 22:12

manager   ~~0018555

Last edited: 2013-06-04 23:50

I've heard similar complaints from players when flying aircraft. (Not a new bug)

Maybe related: setControlState("forwards", true) works flawlessly when you're on your own but on a busy server it'll stop within seconds.

Edit: found a way to reproduce this with an Infernus. I drove around LV on busy (CIT) server, all fine. I then changed game speed to 2 and at about 5 specific points in the route my Infernus' speed would just instantly drop to 0.

kakaksk

2013-07-12 06:33

viewer   ~~0018905

Only happens with aircraft to me (not sure about the helicopters, since the issue happened only one time with them). Also might be related to other players shooting to the plane (or even sound functions). I have no idea which of these can affect the planes, since dont know the code.

CWanted

2013-07-12 14:28

updater   ~~0018907

Happens with all types of vehicles, not just aircraft.
I think, the reason is packet loss and the way MTASA handels it.

kakaksk

2013-07-18 21:08

viewer   ~~0018944

Here is a video http://youtu.be/QNYouCEOARQ

arranTuna

2013-07-19 11:57

manager   ~~0018945

According to shownetstat 1 packet loss was 0.00% throughout the test and as before I was able to reproduce it when I set my game speed to 2 and drove around LV.

At 2:10 and 2:40 of this video: http://www.youtube.com/watch?feature=player_detailpage&v=RpN5XF9Rpno#t=125s

kakaksk

2013-09-19 11:13

viewer   ~~0019353

http://www.youtube.com/watch?v=fnDjrxReZhI related. Look. Its clear that its random and based on shooting. Same things happened in the previous videos of mine. And thats at speed 1x

x86

2013-09-19 16:16

administrator   ~~0019354

Use setAircraftMaxHeight ( 9001 )

kakaksk

2013-09-20 15:31

viewer   ~~0019358

Can't you just try to fix this? What if I don't want to set the max height to 9001?

Cazomino05

2014-07-01 22:35

reporter   ~~0021202

fixed in r6634 - https://code.google.com/p/mtasa-blue/source/detail?r=6634

Issue History

Date Modified Username Field Change