View Issue Details

IDProjectCategoryView StatusLast Update
0007608Multi Theft Auto : San AndreasServerpublic2013-05-19 11:45
ReporterSpajkAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007608: setVehicleLandingGearDown - doesnt always work
Description

I am not sure this is a bug actually, but setVehicleLandingGearDown doesnt do anything if vehicle doesnt have a driver(in this case, pilot) in it. I think it shouldnt matter if there is driver or not.

Additional Information

Tested server-side only. Also, as soon as player/ped leaves the aircraft, landing gear goes down.

TagsNo tags attached.

Relationships

related to 0007621 resolvedccw Source patches Patch for #0007608 (setVehicleLandingGearDown - doesnt always work) 

Activities

sbx320

2013-05-11 08:51

administrator   ~~0018561

Also, as soon as player/ped leaves the aircraft, landing gear goes down.
Can't reproduce that behavior with a Rustler. Which plane did you use for testing?

x86

2013-05-13 12:17

administrator   ~~0018567

Might be a Shamal.

sbx320

2013-05-13 15:03

administrator   ~~0018568

Might be a Shamal.
Cannot reproduce it with a shamal either.

Just checked all planes and I can't seem reproduce that with any of them. Might be a script, I guess.

x86

2013-05-13 20:45

administrator   ~~0018569

So how does your patch fix this issue if you can't reproduce it ?

sbx320

2013-05-13 20:54

administrator   ~~0018570

It fixes the bug stated in the description, which was easily reproducable.

I am not sure this is a bug actually, but setVehicleLandingGearDown doesnt do anything if vehicle doesnt have a driver

CWanted

2013-05-18 20:11

updater   ~~0018579

https://code.google.com/p/mtasa-blue/source/detail?r=5397

Issue History

Date Modified Username Field Change