View Issue Details

IDProjectCategoryView StatusLast Update
0007594Multi Theft Auto : San AndreasServerpublic2017-06-29 15:34
ReporterarezuAssigned Tolopezloo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.4 
Target Version1.5.5Fixed in Version1.5.5 
Summary0007594: setCameraTarget on a player inside a vehicle with hydraulics bugs camera
Description

setCameraTarget on a player inside a vehicle with hydraulics bugs camera

Steps To Reproduce

If a player is inside a vehicle that has hydraulics added server sided and you try to spectate him, then you wont be able to look up or down - only left and right.
The same thing happens if you add hydraulics to his vehicle client sided for you.

Easily fixed by giving hydraulics client sided only for the player that is inside the vehicle, but finding this bug took FOREVER because it doesn't make any sense what caused this to happen.

TagsNo tags attached.

Relationships

related to 0005306 resolvedlopezloo Spectate camera movement malfunctioning with vehicles with adjustable property 

Activities

arezu

2013-05-04 01:17

viewer   ~~0018476

Last edited: 2013-05-04 01:18

Can't seem to edit this report, so here is easy steps to reproduce:

  1. Have two players in server. Lets call one player for player1 and the other for player2
  2. player1 enter vehicle manually or with warpPedIntoVehicle.
  3. addVehicleUpgrade(vehicle, 1087) server sided for the vehicle that player1 is inside.
  4. setCameraTarget(getPlayerFromName("player2"), getPlayerFromName("player1")) and you will see that spectating for player2 is messed up.
    (5). removeVehicleUpgrade(vehicle, 1087) for player1's vehicle and the camera will have its normal behaviour for player2.

qaisjp

2017-06-29 15:34

administrator   ~~0026049

Fixed: GitHub, buildinfo

Issue History

Date Modified Username Field Change