View Issue Details

IDProjectCategoryView StatusLast Update
0007546Source patchesClientpublic2017-03-27 21:46
ReporterLex128Assigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindows 7OS Version6.1.7600
Product Version 
Target VersionFixed in Version 
Summary0007546: setNonHighwayLimiterEnabled, getNonHighwayLimiterEnabled
Description

Disabling speed limiter for non-highway

TagsNo tags attached.

Activities

x86

2013-03-22 11:45

administrator   ~~0018265

Please explain more ...

Lex128

2013-03-22 12:45

reporter   ~~0018268

For example non-highway speed limiter acts on Garver Bridge connecting San Fierro and Las Venturas or the central road where the Las Venturas casinos

This limiter prevents the car to reach high speeds on these roads

x86

2013-03-22 15:32

administrator   ~~0018269

Can't this be done already with vehicle handling (max velocity) ?

star-tR

2013-03-22 16:49

reporter   ~~0018270

http://i.imgur.com/Vf6jGGD.jpg

Lex128

2013-03-22 16:53

reporter   ~~0018271

No, it not dependent on the vehicle handling, it is pure GTA and just Roads

star-tR

2013-03-22 16:56

reporter   ~~0018272

all vehicles has max speed here 180, police which has max 200, taxi, ambulance, cheetah and other. roads have limit, not vehicle.

LooooP

2013-03-22 22:42

reporter   ~~0018273

Last edited: 2013-03-22 22:52

Nonono.
Using http://wiki.mtasa.com/wiki/GetElementSpeed it says that Infernus max speed is 198km/h, I can get this speed anywhere, including Garver Bridge and Las Venturas central street

EDIT: My bad, this limiter works only when nitro is disabled

Remi-X

2013-03-23 02:00

viewer   ~~0018274

@ LooooP
It seems to be there event when nitro is enabled, it's just less noticable. Acceleration seems to be a little bit slower.

I love this patch already. Personally not so sure about the naming of the functions, I'd say, set/isWorldSpeedLimiterEnabled? Meh, who am I.

Kenix

2013-03-23 18:08

updater   ~~0018275

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5199

x86

2013-05-08 13:25

administrator   ~~0018532

Reverted, see comments at r5199.

Lex128

2015-12-04 15:34

reporter   ~~0024212

January 6, 2015 has been left constructive response in https://code.google.com/p/mtasa-blue/source/detail?r=5199 and still no one answers...

qaisjp

2015-12-04 22:24

administrator   ~~0024213

As a note, this was originally reverted in r5205

qaisjp

2015-12-04 23:17

administrator   ~~0024214

Lex128, I've created a pull request here: https://github.com/multitheftauto/mtasa-blue/pull/18

Please can you test my branch?

qaisjp

2016-01-04 18:58

administrator   ~~0024277

If I don't get a response from you within the next month I'm closing my pull request and you'll have to make your own pull request (my branch will remain, feel free to use that as a new branch base).

lopezloo

2016-01-08 02:20

developer   ~~0024307

Maybe instead of creating new function like setOriginalGameplaySetting this could be integrated into setWorldSpecialPropertyEnabled? Currently it's used only for cheats but why not extend it for more options?

qaisjp

2016-01-08 02:21

administrator   ~~0024308

Makes sense. Good idea.

Inspirator

2016-01-08 09:53

viewer   ~~0024309

Just be sure to have the limitations enabled by default or it might mess up certain race maps on servers that have top times.

qaisjp

2016-07-12 02:40

administrator   ~~0024925

A change is required before this can be merged, as outlined here: https://github.com/multitheftauto/mtasa-blue/pull/18#commitcomment-14799592

Please make a new pull request with the relevant changes committed.

ccw

2017-03-27 21:46

administrator   ~~0025776

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/ba64500266e397ed8a15e62bb7e516a0ccd41e44

Issue History

Date Modified Username Field Change