View Issue Details

IDProjectCategoryView StatusLast Update
0007536Multi Theft Auto : San AndreasClientpublic2014-06-14 06:25
ReporterRustyCuylerAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0007536: Binding mouse_wheel_up/down to Sprint makes you run extremely fast
Description

In the Binds menu, setting mouse_wheel_up or mouse_wheel_down to Sprint will make you sprint extremely fast, as if you were using a macro or rapid fire controller.

Steps To Reproduce

Remove mouse_wheel_up or down from Previous and Next Weapon, then bind one of them to Sprint. While walking, scroll your mouse wheel in the direction you binded, and you'll have very high sprinting speed.

Additional Information

Not sure how this could be fixed, or if it's even worth fixing. Just thought I'd post it here.

TagsNo tags attached.

Activities

CWanted

2014-01-13 17:58

updater   ~~0019983

Unable to reproduce.

Dragon

2014-01-14 02:16

reporter   ~~0019986

Cannot confirm this either.

W

2014-01-15 09:10

viewer   ~~0019991

Some mouses probably generate scrolling events at a much higher rate than other ones.

Also, as noted, some players have controllers, that allow rapid fire.

I don't see any possibility to fix it, besides monitoring number of onClientKey events, and kicking/banning players who abuse it. In my observations, 60 clicks per seconds is unobtainable in any normal way, and that's the value I use in my detections.

IIYAMA12

2014-01-19 14:59

viewer   ~~0020012

Mta has it's limits.

I use marco's, but I don't get the feeling that I am running faster then destroy my keyboard by pressing "space" a lot of times.

sbx320

2014-04-06 09:33

administrator   ~~0020591

I assume this can be considered as fixed by ccw in http://code.google.com/p/mtasa-blue/source/detail?r=6277

Issue History

Date Modified Username Field Change