View Issue Details

IDProjectCategoryView StatusLast Update
0007530New issuesServerpublic2013-03-01 10:38
ReporterdennisuniAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0007530: getPedTotalAmmo returns invalid values
Description

I know this bug has been reported a couple of months ago, or maybe even longer, but it's worth reporting it again though.

getPedTotalAmmo serverside returns invalid values while the clientside version of it work fine. These invaid values mostly happen with melee weapons and looks to me as an syncing related issue.

Steps To Reproduce
  1. Give yourself for example a grenade
  2. Run the function serverside 'getPedTotalAmmo', as it should, it returns the correct value, 1 grenade left
  3. Throw the grenade and run the serverside 'getPedTotalAmmo' function again, as you see it'll return a 1 yet again while you're not holding any grenades anymore.

Clientside on the other hand seems to work fine and returns the correct values.

TagsNo tags attached.

Relationships

duplicate of 0006239 resolvedJusonex Multi Theft Auto : San Andreas getPedTotalAmmo does not return the correct values 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change