View Issue Details

IDProjectCategoryView StatusLast Update
0007509Multi Theft Auto : EditorMap Editorpublic2013-02-15 12:37
ReporterBasssAssigned ToarranTuna 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows 7OS Version
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0007509: Weapon model changes to 1337 after saving/loading some times
Description

I've got a map somewhere off the coast of San Andreas with a hut and a rifle cabinet. These rifles, modelid 357, change to modelid 1337 (a trashcan) from time to time. After saving or loading the map, this seems to occur.

This is really annoying. Would be awesome if this could be fixed.

TagsNo tags attached.

Activities

arranTuna

2013-02-12 18:03

developer   ~~0018131

If you really want it fixing, you'll need to find some exact steps to reproduce, no matter how random it may seem, there is something.

Basss

2013-02-12 18:44

viewer   ~~0018132

I tried it in a new map and this is the quickest way to reproduce it:

  1. Create a new map and spawn some weapon models.
  2. Save the map.
  3. Close the map.
  4. Reopen the map.
  5. Save the map.
  6. Close the map.
  7. Reopen the map.
  8. The weapon models are now all trash cans. :(

Any idea how I can edit the original issue to add this?

Basss

2013-02-12 18:47

viewer   ~~0018133

Last edited: 2013-02-12 18:47

Of course nobody opens the same map several times in a row. But this happens also on longer time distances. If I place the weapons on day 1 for example, and I edit the map every day. On day 3 they would change to trashcans too.

arranTuna

2013-02-12 20:06

developer   ~~0018134

By weapon models, do you mean weapon pickups or those weapon objects?

Does the ID in the map file change to 1337 and if so is it when you saved it or when you loaded it and it loaded wrong?

Basss

2013-02-12 20:30

viewer   ~~0018135

I mean the weapon object models. When you place an object and you set its model to that of a weapon.

After point 5, the second save, modelid 1337 will appear in the map file. After the first save the modelid is correctly saved, but after the second save it changes to 1337.

If after point 4, I click the object and press F3, it does show the correct modelid.

If I don't do point 6 and keep the map open, the modelid 1337 will stay in the file when I save again. If I move the model, it updates the position in the file when I save, but it still prints 1337 as modelid, while the model ingame is still the weapon model.

arranTuna

2013-02-12 21:09

developer   ~~0018136

Thanks to your further information fixed in http://code.google.com/p/mtasa-resources/source/detail?r=910

Basss

2013-02-12 22:52

viewer   ~~0018140

Thanks! That seems to the fix. :)

Issue History

Date Modified Username Field Change