View Issue Details

IDProjectCategoryView StatusLast Update
0007372Multi Theft Auto : San AndreasClientpublic2013-08-25 05:43
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.4Fixed in Version1.3.4 
Summary0007372: Applying weapon mods may remove your weapon
Description

If you apply a modification to a weapon (TXD/DFF stuff) that weapon may disappear from your inventory but you'll still be said to have it if you checked server side.

I was unable to reproduce this with just 1 weapon mod but with 2 I was able to reproduce it every time. If I apply a mod to colt 45 and then the M4, if I had both of those weapons, my colt 45 would disappear every time.

Steps To Reproduce

Go on freeroam
Give yourself a Colt and an M4
start loseWeapon (see attached)
Then do /applymod
Scroll your weapons to observe that the colt 45 has vanished.

TagsNo tags attached.

Activities

BrianAndrews

2013-08-16 21:53

viewer   ~~0019158

Last edited: 2013-08-24 09:16

View 2 revisions

Confirmed, this is getting a big problem for players as they can't enjoy custom weapons models.

EDIT: The only way to apply mods without making players lose weapon is to reconnect them as soon as they trigger function.

ccw

2013-08-25 05:43

administrator   ~~0019194

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=5752

Issue History

Date Modified Username Field Change