View Issue Details

IDProjectCategoryView StatusLast Update
0007350Multi Theft Auto : San AndreasClientpublic2012-09-24 10:33
Reportertinostar91Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSOS Version
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007350: FarClipDistance is reseting each respawn
Description

If you will set FarClipDistance to number like 6000 and then respawn, it will be reseted for player but number executed by getFarClipDistance() will stay 6000

Steps To Reproduce
  1. /run setFarClipDistance(6000) - FarClip will be set correctly
  2. /run spawnPlayer(getPlayerFromNick("tinostar91"),0,0,3) - after this FarClipDistance will looks like reseted
  3. /run getFarClipDistance() - will execute 6000
TagsNo tags attached.

Activities

StifflersMom

2012-09-23 14:32

updater   ~~0017617

Last edited: 2012-09-23 14:39

Would add a similar bug, but I decided to use this one, because I have a set of reproduceable steps to confirm this:

Change your position to:
sp -22.53652 -5.01489 3.11719

On client:
crun setFarClipDistance(2500)

also set Fog Distance to a higher value, because you can see the change:
crun setFogDistance(1000)

Run to the position as shown at the video:
http://www.youtube.com/watch?v=qf9oxIU-t9I

If you reach this position, a setFarClipDistance(2500) will be reset immediately.

Edit: @tinostar91 if you set the farclip server side, you never notice a client change. Try it client side, you can do a getFarClipDistance() and you will see the change :-)

tinostar91

2012-09-23 14:59

viewer   ~~0017618

Last edited: 2012-09-23 17:31

Yep, I see that client-side change now but it's sometimes reseting right after setting (changing via bind):
http://youtu.be/epZGl67O9v8

//edit It looks like that it's not by respawn (http://youtu.be/JvlGrpIbw38 ) , but that area should be bugged, it also doesn't happens in certain alt, vids:
area: http://youtu.be/35jwCU3E81w
altitude: http://youtu.be/xlUSND-STVo

Issue History

Date Modified Username Field Change