View Issue Details

IDProjectCategoryView StatusLast Update
0007335Multi Theft Auto : San AndreasClientpublic2018-09-02 20:45
ReporterMGSAssigned Toccw 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version 
Target VersionFixed in Version1.3.2 
Summary0007335: Chinese characters in chat stalls the game
Description

We have problem when any Chinese player write Chinese in the chat all the players have lag/hang each time chinese characters written in chat

TagsNo tags attached.

Relationships

has duplicate 0006855 closedqaisjp New issues "outputChatBox" reduce fps when it includes korean characters. 

Activities

ccw

2012-09-15 13:44

administrator   ~~0017575

Does the stall occur if you repeat the same message?
Or it it only when new characters are displayed?

Hyunsu2

2012-09-15 14:29

viewer   ~~0017576

Korean has same problem.

To grasp the problem in detail, i made script that outputs repeatedly and quickly same message.

But there weren't lags in this case.

MGS

2012-09-15 21:07

reporter   ~~0017577

I have no idea if its new character or not .. man ! its Chinese characters :\

New characters or repeated no difference if its cause lag

W

2012-09-15 21:14

viewer   ~~0017579

Last edited: 2012-09-17 08:15

Test resource: http://lss-rp.pl/_/7335.zip
Test command: /7335

On my computer (mta under wine), very small delay occurs when a line is displayed for a first time, there's no delay after a repetition of the same line.

W

2012-09-17 08:17

viewer   ~~0017589

I've retested with v1.4-unstable-4680 and problem still occurs, only when characters are displayed for the first time.

My MTA setup is nowhere near standard one, so it would be better if someone else retest it too.

ccw

2012-10-27 01:02

administrator   ~~0017824

Last edited: 2012-10-27 01:02

Thanks for the test resource - There no delay in native Windows (here).
I guess it is Wine's DirectX implementation causing the initial pause for you (probably caching the new characters).

btw - Make sure the client console is closed when testing (to keep CEGUI out of the way)

qaisjp

2018-07-24 23:57

administrator   ~~0026883

probably fixed in https://github.com/multitheftauto/mtasa-blue/commit/30e5abc6a3bddc49384f2071da5e787d04b2a388

Issue History

Date Modified Username Field Change