View Issue Details

IDProjectCategoryView StatusLast Update
0007311Multi Theft Auto : EditorMap Editorpublic2013-03-02 12:01
ReporterNikDelgadAssigned ToarranTuna 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0007311: Map editor doesn't load object properly but race gamemode does.
Description

This isn't the first time it happend to me. The deal is that when I today entered editor it deleted or hid some object on the end of the map,then I started the map in race gamemode and it shows the objects but still no objects in the editor.

Race - https://dl.dropbox.com/u/9259344/editor/mta-screen_2012-09-07_14-52-27.png
Editor - https://dl.dropbox.com/u/9259344/editor/mta-screen_2012-09-07_14-53-23.png

Race - https://dl.dropbox.com/u/9259344/editor/mta-screen_2012-09-07_14-52-30.png
Editor - https://dl.dropbox.com/u/9259344/editor/mta-screen_2012-09-07_14-53-25.png

  • when I check .map all objects are there.
TagsNo tags attached.

Activities

arranTuna

2012-09-08 00:46

developer   ~~0017483

Is this something new, do you know when it first happened?

Maybe something to do with the streaming of the objects.

Jaysds1

2012-09-08 03:35

viewer   ~~0017484

by looking at the bottom right, it looks new

NikDelgad

2012-09-08 10:31

viewer   ~~0017488

It happend to me in 1.3, before this editor update. I just didn't report it then. If needed I can upload the map.

arranTuna

2012-09-08 12:15

developer   ~~0017489

Do they reappear when you get closer to them?

Are they in the object list? ("Browse current elements" I think)

NikDelgad

2012-09-08 12:19

viewer   ~~0017490

Last edited: 2012-09-08 12:22

They don't appear when I get close neither they are in the current element list.

That would explain why they aren't loaded but why they would be still in the .map file? I can clearly see objects that aren't loaded in the editor there.

arranTuna

2012-09-08 12:26

developer   ~~0017491

Is there a map file that makes this bug easy to reproduce?

NikDelgad

2012-09-08 12:46

viewer   ~~0017492

https://dl.dropbox.com/u/9259344/editor/godfather.zip teleport to the infernus spawnpoint, you'll see some pyramids(they are on the pictures in the description) some of them are missing. Stop the editor, start race gamemode and then start godfather map. You'll be spawned at the spawnpoint an pyramids will be there and the objects that are missing too.

arranTuna

2012-09-08 17:38

developer   ~~0017494

ERROR: Bad/missing 'posX' attribute in <vehicle> (line 985)

Which is causing all the items below it to not get loaded in map editor. For some reason your 2 vehicles didn't have positions, removing those broken vehicles worked. I added an Infernus and it had a posX posY and posZ so either an error occured when they were being saved or you have an editor plugin that affected it.

NikDelgad

2012-09-08 17:47

viewer   ~~0017495

Well I guess it was a problem from my side, it can be closed. Thanks for helping!

arranTuna

2012-09-08 23:36

developer   ~~0017502

Ideally loadMapData and maps defined in meta should continue to load other map elements rather than aborting because one element didn't have a required attribute. It doesn't fix this problem being any where near as serious as it is should this ever happen in other circumstances.

arranTuna

2013-03-01 18:28

developer   ~~0018203

To fix this I will either have to find out how sometimes the required attributes weren't being set or create a verifier to make sure the map works.

arranTuna

2013-03-01 21:23

developer   ~~0018204

Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=913

Made it so that if somehow posX/Y/Z element data isn't set, it'll use getElementPosition.

Issue History

Date Modified Username Field Change