View Issue Details

IDProjectCategoryView StatusLast Update
0007308Multi Theft Auto : San AndreasMap Editorpublic2012-10-04 22:07
ReporterLooooPAssigned ToarranTuna 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007308: Locked Time isn't set correctly
Description

Locked Time option on Map Editor isn't set correctly when opening a map or coming back from a testing

Steps To Reproduce

Open a map with Locked Time option set to true, you'll notice Locked Time will be set as false, you'll have to set it to true again manually, same happens when coming back from a testing

Additional Information

MTA:SA Resource r874

TagsNo tags attached.

Activities

LooooP

2012-09-07 05:12

reporter   ~~0017474

  • Gravity isn't set correctly too, instead of 0.008 (default) it's set to 0.0080000003799796

arranTuna

2012-09-07 12:58

manager   ~~0017476

The gravity thing is impossible to fix as that is due to a computing limitation called floating point inaccuracy. Computers don't store floats as exactly as you specified, they change slightly.

ccw

2012-09-08 08:18

administrator   ~~0017486

Yes, the gravity value is a rounding error due to the use of 32bit floats.
You can check them here: http://www.h-schmidt.net/FloatConverter/IEEE754.html

Type 0.008 into the 'Decimal Representation' box.
Press return.
Look at the number in the bottom box.

arranTuna

2012-09-28 23:38

manager   ~~0017644

Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=892

Issue History

Date Modified Username Field Change