View Issue Details

IDProjectCategoryView StatusLast Update
0007306Multi Theft Auto : San AndreasClientpublic2012-09-12 10:51
ReporterStifflersMomAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXP and 7 32 and 64bitOS Version
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007306: setFarClipDistance() causes client crashes
Description

setFarClipDistance(3000) as described at the wiki causes client crashes at some reproduceable situations.

Steps To Reproduce

setFarClipDistance(3000) (serverside, like the example at the wiki)

Position:
sp 1544.66113 -1352.23669 329.48294

You are on the heli platform on 330m height building.

Go to one of the 9 edges of the platform.
Change the cam view to look down to the city.
Change the view angle a little bit. Notice the absolutely high cpu usage, while objects on the ground are flickering wild.

change the cam view to normal horizontal view (without flickering anything).
Get a vehicle (preferred bullet or dumper) and get into the vehicle.

Change the cam view angle a little bit around - crash!

Additional Information

crashdump attached.

TagsNo tags attached.

Activities

_Spanish4Life

2012-09-05 20:52

viewer   ~~0017464

Last edited: 2012-09-05 20:59

Can you make a video of this?
EDIT: Can reproduce CPU/shaking but not crash

StifflersMom

2012-09-05 23:49

updater   ~~0017466

http://www.youtube.com/watch?v=wpk2Or8Ponk

Windowed mode, 1024x768x32 mta window.
I do not recorded it with fraps, because you don't see the error and the CPU with fraps...

tinostar91

2012-09-08 17:53

viewer   ~~0017496

Started SP, went to the skyscraper and there is one difference. World doesn't start flickering but some textures will disappear so it should be core game problem. I've just updated my drivers so it cannot be problem with drivers (ATI Mobility Radeon HD 4650)
How it is:
http://i45.tinypic.com/i6m9gw.jpg
How it must looks like:
http://i50.tinypic.com/4qr6ko.jpg

StifflersMom

2012-09-08 21:52

updater   ~~0017497

Last edited: 2012-09-08 21:55

Some adittional info: all gta installations are from a DVD labeled SA_GER_201B, which is downgraded with the 1.0 NOCD Patch. I use this installation too for years now without any problem. We could reproduce it on every machine we have.

Adittionally, we have checked it with a clean server installation, only with freeroam and gamemode "play" with the same crash result.

Edit: Checked with Nvidia GTX 280, Nvidia Quadro NVS, ATI Raedon HD 4570 mobile, with all the same result.

ccw

2012-09-08 22:01

administrator   ~~0017498

Running with Fraps fixes the problem?

StifflersMom

2012-09-09 01:00

updater   ~~0017503

No, fraps fixes not the crash. I have not recorded with fraps, because the recording ends suddenly, if client crashes.
I have added a new video recorded with fraps, you can watch it with 720p and see the flickering objects with setFarClipDistance(3000). Additionally we can reproduce the same behaviour on a 1.2 Server / Client version.

http://www.youtube.com/watch?v=vNZklqpENZI

StifflersMom

2012-09-11 16:45

updater   ~~0017534

Deinstalled the GTA installation from SA_GER_201B DVD and installed from a real 1.0 DVD. Same crash, so it should be reproduceable everywhere. Sometimes, it's difficult to reproduce it with a bullet, getting a dumper on the skyscraper, get in and then change the view angle crash it in one second.

ccw

2012-09-12 05:38

administrator   ~~0017545

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4651

This for the crash - The flickering is not going to be so easy to fix

Issue History

Date Modified Username Field Change