View Issue Details

IDProjectCategoryView StatusLast Update
0007283Multi Theft Auto : San AndreasServerpublic2012-09-16 22:22
Reporter1PAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007283: setElementFrozen() kills player.
Description

setElementFrozen() kills player.

TagsNo tags attached.

Activities

DakiLLa

2012-08-30 09:37

viewer   ~~0017406

Any proper steps to reproduce ?

arranTuna

2012-08-30 12:44

manager   ~~0017408

He probably means when they're unfrozen, the ped can fall and die from a really small drop.

1P

2012-08-30 16:08

viewer   ~~0017409

Steps To Reproduce:

  1. setElementPosition() to place where is not ground, for example: sky.
  2. setElementFrozen()

I have own interior system using createObject(). I always die after a few seconds when i enter to a interior.

W

2012-08-30 22:52

viewer   ~~0017414

You're reports are invalid. The code you provided is incomplete, and does not 'kill the player'.

http://i.imgur.com/rly03.png - ped isn't dying as you can see.

Did Arran guess your problem correctly or is it something else?

H5N1[PL]

2012-08-31 14:15

viewer   ~~0017418

I think he means that setElementFrozen only holds the position of the player, but he is accelerating. When your ped is unfrozen it falls with high speed and dies. It's possible to fix it in mta by using setElementVelocity so I think it's not a bug.

arranTuna

2012-09-16 12:33

manager   ~~0017582

1.4: http://code.google.com/p/mtasa-blue/source/detail?r=4666

1.3.1: http://code.google.com/p/mtasa-blue/source/detail?r=4670

Issue History

Date Modified Username Field Change