View Issue Details

IDProjectCategoryView StatusLast Update
0007280Multi Theft Auto : San AndreasClientpublic2012-08-29 10:49
ReporterMrMuLTiVaNAssigned Toccw 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMDOSWindowsOS Version7
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007280: getSoundLength returns 0 for sound streams(not radio streams)
Description

Tested it sometimes, It does not work.

It would be great to fix this, because I can't work on my radio script yet, because I can't update the sound position with a GUI-Scrollbar without the length of this sound.

Steps To Reproduce

execute this:
sound = playSound("http://noneatme.vps20642.alfahosting-vps.de/backgroundmusic/1.mp3", false)
getSoundLength(sound)

And then your done.

TagsNo tags attached.

Activities

1P

2012-08-28 20:41

viewer   ~~0017396

Right.

Jusonex

2012-08-28 22:07

administrator   ~~0017397

Patch uploaded: https://dl.dropbox.com/u/53602417/fix_7280_CClientSound.cpp.patch

In your example, you have to call "getSoundLength" after a should delay (because the stream has not been initialized yet).

MrMuLTiVaN

2012-08-28 22:29

viewer   ~~0017398

@Jusoney I am sorry but I have no idea what I should do with this file. I'm just a lua developer D:

Jusonex

2012-08-28 23:05

administrator   ~~0017399

You've to wait until the source patch (the file ;) ) has been installed into the mta source (if it will be accepted, of course)

MrMuLTiVaN

2012-08-28 23:28

viewer   ~~0017400

Ah okay :D:D

ccw

2012-08-29 02:54

administrator   ~~0017401

Last edited: 2012-08-29 02:55

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4577

Thanks Jusonex

Issue History

Date Modified Username Field Change