View Issue Details

IDProjectCategoryView StatusLast Update
0007276Multi Theft Auto : San AndreasServerpublic2012-08-29 10:46
ReporterSHC//SniperAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSDebian SqueezeOS Version
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007276: Make setVehicleIdleRespawnDelay work for non-streamed in vehicles
Description

Allright, the basic problem regarding setVehicleIdleRespawnDelay is the fact that it is not working unless the vehicle has a streamer. Thus causing most vehicles to get lost somewhere on the San Andreas map. The only "real" way to make sure an empty vehicle is respawned is to set a timer, loop all the empty vehicles and do respawnVehicle manually. Unfortunately it's the most inconvenient way to respawn more 500 vehicles as the server freezes for at least 1-2 seconds which is unacceptable with more than 100 players.

Steps To Reproduce

-Create a vehicle with an idle respawn delay
-Drive to a place where you would be able to find the vehicle again
-Disconnect immediately and reconnect after the idle respawn delay should have passed
-Drive to the place where the vehicle has been left
-The vehicle is still there even though the time passed

TagsNo tags attached.

Activities

qaisjp

2012-08-26 21:52

administrator   ~~0017375

Last edited: 2012-08-26 21:55

BUMP! This is really important as respawning in the resource I am creating is really needed, since not all players occupy all parts of the map at a time (the map is really big, one massive model) this is a problem that I need solving ASAP

arranTuna

2012-08-26 23:00

manager   ~~0017377

According to the documentation and my experience of using this conflicts with your report as the documentation defines not idle as "The vehicle is considered occupied if anyone is within streaming range."

But you're saying that it will only respawn when it has a streamer which is the opposite of the functions description.

"toggleVehicleRespawn must be set to true for this function to work. "

Maybe you forgot that?

SHC//Sniper

2012-08-26 23:17

reporter   ~~0017378

Last edited: 2012-08-26 23:20

Nono! I surely did not forget that. Idle respawn is working perfectly when there is a streamer around.

I have reproduced it several times and the the main issue on my public server is:
"Thus causing most vehicles to get lost somewhere on the San Andreas map."

There is one strange thing I noticed: All my vehicles have small blips attached. Somehow the blip's position gets reset to the actual spawn position while the vehicle stays where it was left.

It could be a problem regarding the idle respawn sync.

ccw

2012-08-26 23:20

administrator   ~~0017379

I think the documentation is wrong and the vehicle is considered idle when there are no occupants.

SHC//Sniper

2012-08-27 19:40

reporter   ~~0017392

Uhm, so is it possible to fix this issue?

x86

2012-08-27 19:42

administrator   ~~0017393

Please stop crying, qaisjp and Sniper.

Issue History

Date Modified Username Field Change