View Issue Details

IDProjectCategoryView StatusLast Update
0007265Multi Theft Auto : San AndreasServerpublic2012-08-24 13:54
Reporter1PAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007265: Connect problem when using a domain name that starts with a number
Description

The problem is a string with number as IP adress.

For example:

connect domain.com 22003 - works
connect 1domain.com 22003 - never dosent work

Please fix that bug because it is important for some people.

TagsNo tags attached.

Activities

W

2012-08-23 10:37

viewer   ~~0017355

Last edited: 2012-08-23 10:39

I can confirm this issue.
MTA tries to connect with 255.255.255.255 in such cases:

root@onomatopeja:/home/lukasz# tcpdump -i eth1 -n port 22003
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes
10:36:57.159966 IP 10.39.4.244.56295 > 255.255.255.255.22003: UDP, length 34
10:36:57.664115 IP 10.39.4.244.56295 > 255.255.255.255.22003: UDP, length 34
10:36:58.167479 IP 10.39.4.244.56295 > 255.255.255.255.22003: UDP, length 34
10:36:58.668992 IP 10.39.4.244.56295 > 255.255.255.255.22003: UDP, length 34

1P

2012-08-23 10:44

viewer   ~~0017356

There should be "never works" - sorry for the mistake.

ccw

2012-08-24 03:01

administrator   ~~0017358

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4560

Issue History

Date Modified Username Field Change